Failed to process alert transport

Like others, I’m receiving the ‘failed to process alert transport’ when setting up any kind of alert transport, I’ve tried email, slack and a few others. They all give the same error.

I’ve read that sometimes it can be caused by DNS, but DNS seems fine. validate.php says everything is good… Is there any other debug logs that I can look to determine why it’s failing?

$ ./validate.php

Component Version
LibreNMS 23.6.0-14-g6901884d4 (2023-06-27T23:26:01-04:00)
DB Schema 2023_04_27_164904_update_slas_opstatus_tinyint (252)
PHP 8.1.20
Python 3.6.8
Database MariaDB 10.5.21-MariaDB
RRDTool 1.7.0
SNMP 5.8

[OK] Composer Version: 2.5.8
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[OK] rrd_dir is writable
[OK] rrdtool version ok

Figured it out - of course, when you’ve been working on it for hours… you figure it out as soon as you post on the forums.

There was no internal SMTP daemon running (sendmail…) once I installed sendmail and started it, I was able to create the transport… (even though I was adding the slack transport, which shouldn’t be using email).

Weird behavior, but whatever.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.