False positive service alerts

Hi Guys,

I’m getting many false positive alerts when using service check of Nagio plugin, please see attached image:
Also I’ve adjusted fping checks to the following values but it didn’t help, please advise
#$config[‘update’] = 0;
$config[‘fping’] = “/usr/sbin/fping”;
$config[‘fping_options’][‘retries’] = 3;
$config[‘fping_options’][‘timeout’] = 1000;
$config[‘fping_options’][‘count’] = 3;

if you already adjusted the fping options then I suggested you need to troubleshoot further and see why those devices are timing out. Could be a number of things.

fping doesn’t have anything to do with service checks.

run the service check on the commandline with the -h option to figure out options for it.

What does it mean? fping parametars on config.php isn’t related to fping checks for service alerts?

How can I see the logs when it fails, i want to see the reason

Exactly this is two different things. You need ton add options to the services settings directly if you want to fine tune your options for the service check.

Where I can adjust timeouts of fping checks related to “%services.service_ip” event

You need to check the official documentation for your fping Nagios plugin. Depending on which version you’re using the options are different. I’ve found this, but I can’t be sure that the same as you’re using:

 -h, --help
    Print detailed help screen
 -V, --version
    Print version information
    Read options from an ini file. See
    for usage and examples.
 -4, --use-ipv4
    Use IPv4 connection
 -6, --use-ipv6
    Use IPv6 connection
 -H, --hostname=HOST
    name or IP Address of host to ping (IP Address bypasses name lookup, reducing system load)
 -w, --warning=THRESHOLD
    warning threshold pair
 -c, --critical=THRESHOLD
    critical threshold pair
 -b, --bytes=INTEGER
    size of ICMP packet (default: 56)
 -n, --number=INTEGER
    number of ICMP packets to send (default: 1)
 -T, --target-timeout=INTEGER
    Target timeout (ms) (default: fping's default for -t)
 -i, --interval=INTEGER
    Interval (ms) between sending packets (default: fping's default for -p)
 -S, --sourceip=HOST
    name or IP Address of sourceip
 -I, --sourceif=IF
    source interface name
 -v, --verbose
    Show details for command-line debugging (output may be truncated by
    the monitoring system)

Check_fping is written in gibberish, I don’t see any values which specifies default parameters

Paste here your service configuration please.

Do you mean check_fping file?

No, you service configuration under Services menu in LibreNMS, where you’re selecting the check_fping module.

Please see below:

The options that I showed you in a precedent message must be added to the “Parameters” field.

Got it, so if I want it to be like this
$config[‘fping_options’][‘retries’] = 3;
$config[‘fping_options’][‘timeout’] = 1000;
$config[‘fping_options’][‘count’] = 3;
$config[‘fping_options’][‘millisec’] = 1000;

I should add in Parameters” field -T 1000 -i 1000 -n 3?
What about retry option?

-T 1000 -i 1000 -n 3
This one works properly

Nice, happy that’s working now.