Fix: Please install mysqlnd

Hello, I’m looking for assistance on how to fix the issue below. PHP had been validating the last few weeks but somehow today it’s getting an error.

[[email protected] ~]$ ./validate.php

Component Version
LibreNMS 1.42.01-64-gfefde75
DB Schema 260
PHP 7.0.30
MySQL 5.5.56-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.7.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[FAIL] Missing PHP extension: mysqlnd
[FIX] Please install mysqlnd

[[email protected] librenms]# yum install php-mysqlnd
!
!
–> Finished Dependency Resolution
Error: php70w-common conflicts with php-common-5.4.16-45.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

@Chris_Andrade

You are running php70, so your command should be:

yum swap php70w-mysql php70-mysqlnd

That will change mysql driver to mysqlnd.

Validation has changed because we ran into some bugs in the old mysql driver. We wanted to alert all the users that installed before we changed the install docs to use mysqlnd several months ago.

I think mysqlnd is the default on Ubuntu.

Tried the swap but still getting an error. See below.

[[email protected] librenms]# yum swap php70w-mysql php70-mysqlnd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 12 kB 00:00:00

  • base: mirror.keystealth.org
  • epel: mirrors.xmission.com
  • extras: mirror.sjc02.svwh.net
  • updates: mirrors.cat.pdx.edu
  • webtatic: us-east.repo.webtatic.com
    base | 3.6 kB 00:00:00
    epel | 3.2 kB 00:00:00
    extras | 3.4 kB 00:00:00
    updates | 3.4 kB 00:00:00
    webtatic | 3.6 kB 00:00:00
    (1/2): epel/x86_64/updateinfo | 939 kB 00:00:00
    (2/2): epel/x86_64/primary | 3.6 MB 00:00:01
    epel 12659/12659
    No package php70-mysqlnd available.
    Error: swap install php70-mysqlnd

I’m using Centos7, not sure if it makes a difference.

ok, i tried it with the following and it fixed my issue.

yum swap php70w-mysql php70w-mysqlnd

Oh! My fault!!! Very sorry. I wrote the package incorrectly :stuck_out_tongue:

Thanks for all your help!!!