Fresh install - Stage 2 - Unauthorized

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hi there,

When I have almost finished fresh install on Centos 7 with Apache, on stage 2 I have the following error:

Unauthorized

Files .env and config.php.default are ok. I can login into DB with librenms user.

Any idea?

Thanks in advance

Hello,

If you put all the settings in “config.php.default”,copy the file to config.php in the same directory. If still no luck, try checking /opt/librenms/logs/librenms.log

Hello Chas, thanks for the reply,

We tried to copy and edit config.php.copy to config.php and when I try to access to librenms.com/install.php, redirect to librenms.com/login and shows me 404 not found…

Not Found

The requested URL /login was not found on this server.

Is this the doc you followed? https://docs.librenms.org/Installation/Installation-CentOS-7-Apache/

Check base_url is set to default “/” in config.php

If you use a reverse proxy see here https://docs.librenms.org/Support/FAQ/#my-reverse-proxy-is-not-working

can you post output of
./validate.php

and contents of config.php and apache config.

Yes, I followed this documentation

config.php

$config[‘db_host’] = ‘localhost’;
$config[‘db_port’] = ‘3306’;
$config[‘db_user’] = ‘librenms’;
$config[‘db_pass’] = ‘password’;
$config[‘db_name’] = ‘librenms’;
$config[‘user’] = ‘librenms’;
$config[‘base_url’]= “/”;
$config[‘auth_mechanism’] = “mysql”; # default, other options: ldap, http-auth
$config[‘http_auth_guest’] = “guest”;
$config[‘rrd_purge’] = 0;
$config[‘enable_billing’] = 1;
$config[‘show_services’] = 1;

validate.php

Component Version
LibreNMS 1.56-16-gae84049
DB Schema 2019_10_03_211702_serialize_config (144)
PHP 7.2.22
MySQL 10.3.18-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.9.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] You have not added any devices yet.
[FIX]:
You can add a device in the webui or with ./addhost.php
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN] Your local git contains modified files, this could prevent automatic updates.
[FIX]:
You can fix this with ./scripts/github-remove
Modified Files:
LibreNMS/Alert/Transport/Mattermost.php
LibreNMS/Alert/Transport/Opsgenie.php
LibreNMS/OS/ArrisDsr4410md.php
addhost.php
adduser.php
alerts.php
artisan
billing-calculate.php
build-base.php
check-services.php
config.php.default
config_to_json.php
contrib/convert-mib-graphs.sh
contrib/findit
cronic
and 118 more…

apache

<VirtualHost *:80>
DocumentRoot /opt/librenms/html/
ServerName librenms.example.com

AllowEncodedSlashes NoDecode
<Directory /opt/librenms/html/>
Require all granted
< /Directory>
< /VirtualHost>

hmm not too sure how so many files can become modified,

I would try

  • fix all those modified files in your validate.php with ./scripts/github-remove
  • chown -R librenms:librenms /opt/librenms
  • Run ./daily.sh - check output
  • Ensure apache config is same as doc, your missing two lines.
  • Check sestatus and if selinux is enforcing then you need to run those commands in the docs or turn it off.