Galera date inconsistency when running validate

22.6.0 version

I just setup a galera databasewith 3 pollers and all three running galera.

Database: incorrect column (users/created_at)
[FIX]:
Run the following SQL statements to fix it
SQL Statements:
SET TIME_ZONE=’+00:00’;
ALTER TABLE notifications CHANGE datetime datetime timestamp NOT NULL DEFAULT ‘1970-01-02 00:00:00’ ;
ALTER TABLE users CHANGE created_at created_at timestamp NOT NULL DEFAULT ‘1970-01-02 00:00:01’ ;

If I run the option to fix it, the problem shifts to the other system. The fix syntax is the same across all three systems. They all have the same timezones set for php, mariadb, and system.

I cannot find anything to change. The systems are all cloned from the main NMS1 VM so everything is the same aside from changing the host specific stuff and RRD location to point to a single server.

I tried dropping the two tables and re adding them but the problem keeps moving around.

right now if I run the alter database commands on NMS1, NMS2 and NMS3 complain. If I run the command on NMS2 or NMS3, NMS1 complains.

Is there something I missed changing when I cloned the VMs from NMS1?

I ended up breaking the cluster apart, dropping the database on two nodes, then re-added and ran the following commands on the two complaining nodes and rejoining them to the cluster. Everything appears to be working properly.

./lnms migrate
./scripts/composer_wrapper.php install --no-dev
php includes/sql-schema/update.php

Was the system timezone set to the same on all three systems?

All three systems were cloned from an existing NMS with the timezone already set.