Getting "message":"Unauthenticated." when trying to use api with token

Trying to integrate Oxidized into lmns.

If I use the router.db, everything work flawlessly.

The issue arises when attempting to use the api to get devices from lmns and feed into oxidized.

I created a global read only user, created an api key for the account. Triple checked the api key copied correctly, even tried typing manually. Then added it to my oxidized config

default: http
debug: true
url: http://<lmns_ip>:8000/api/v0/oxidized
name: hostname
model: os
group: group
X-Auth-Token: ‘<auth_token>’

If I test the token with curl it returns the follolwing

curl: (3) Failed to convert <auth_token>’ to ACE; string contains a disallowed character

HTTP/1.1 401 Unauthorized
Server: nginx
Content-Type: application/json
Transfer-Encoding: chunked
Connection: keep-alive
Keep-Alive: timeout=10
Cache-Control: no-cache, private
Date: Fri, 07 Jan 2022 22:55:05 GMT

Oxidized config on lmns:

I’ve tried remaking the api token about a million times. I’m not sure what I am missing here

I had accientally repeated the “:source” section in the config.

Issue resolved