Getting "problem with backend" error with top devices/top interface widgets


#1

Hi folks,

So for some reason I get “problem with backend” when I try to bring up either the Top Devices or Top Interface widgets.

bash-4.2$ /opt/librenms/validate.php

Component Version
LibreNMS 1.49-94-g96797aa
DB Schema 2019_02_10_220000_add_dates_to_fdb (132)
PHP 7.2.14
MySQL 5.5.60-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.8.4
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
[FIX]:
Check your poll log and see: http://docs.librenms.org/Support/Performance/
Devices:

[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

bash-4.2$ ./daily.sh
Updating to latest codebase OK
Updating Composer packages OK
Updated from f520933 to 96797aa OK
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK

I saw some previous threads on this that seemed to relate to specific older branches of the code. Any idea what is going on?


#2

So the problem comes and goes.


#3

I’m also having the issue. No problems in validate.php. Hopefully I find the time to look into this.