Getting Undefined array key "ospfv3" error

My LibreNMS log shows this:

[2025-03-14T11:39:38][ERROR] Undefined array key "ospfv3" {"view":{"view":"/opt/librenms/resources/views/layouts/librenmsv1.blade.php","data":[]},"userId":1,"exception":"[object] (Spatie\\LaravelIgnition\\Exceptions\\ViewException(code: 0): Undefined array key \"ospfv3\" at /opt/librenms/app/Http/ViewComposers/MenuComposer.php:185)
[previous exception] [object] (ErrorException(code: 0): Undefined array key \"ospfv3\" at /opt/librenms/app/Http/ViewComposers/MenuComposer.php:185)"}

Validation looks fine:

librenms@libre:~$ ./validate.php
===========================================
Component | Version
--------- | -------
LibreNMS  | 25.2.0-60-g25bf9dc4f (2025-03-14T00:08:29-04:00)
DB Schema | 2025_01_30_214311_create_ipv6_nd_table (320)
PHP       | 8.3.17
Python    | 3.12.3
Database  | MariaDB 10.11.8-MariaDB-0ubuntu0.24.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.4.pre2
===========================================

[OK]    Composer Version: 2.8.6
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQL and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[OK]    Python poller wrapper is polling
[OK]    Redis is unavailable
[OK]    rrd_dir is writable
[OK]    rrdtool version ok

My daily.sh completes fine:

librenms@libre:~$ ./daily
bash: ./daily: No such file or directory
librenms@libre:~$ ./daily.sh
Updating to latest codebase                        OK
Updating Composer packages                         OK
Updating SQL-Schema                                OK
Updating submodules                                OK
Cleaning up DB                                     OK
Fetching notifications                             OK
Caching PeeringDB data                             OK
librenms@libre:~$

When I try to load the LibreNMS page I get:

Whoops, looks like something went wrong. Check your librenms.log. 
Check your log for more details. (librenms.log)

If you need additional help, you can find how to get help at https://docs.librenms.org/Support.

Not sure how to proceed from here. Anything else I can check?

Hi!

I have the same problem as you.
I update from 25.1.0 to 25.3.0, the updating proces was ok

===========================================
Component | Version
--------- | -------
LibreNMS  | 25.3.0 (2025-03-17T00:10:07+01:00)
DB Schema | 2025_03_11_031114_drop_ospfv3ifinstid (321)
PHP       | 8.3.6
Python    | 3.12.3
Database  | MariaDB 10.11.8-MariaDB-0ubuntu0.24.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.4.pre2
===========================================

[OK]    Composer Version: 2.8.6
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQL and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[FAIL]  Some poller nodes have not checked in recently
        Inactive Nodes:
         myVM
[OK]    Redis is unavailable
[OK]    rrd_dir is writable
[OK]    rrdtool version ok

I’m going to start debugging

Solved automatically after the first polling…
All fine!