Ghost Ports Showing Down

I have an issue where LibreNMS reports an amount of ports down then doesn’t show any ports when looking for “Down” ports. My only thought is that when a device with several down ports is added then the ports are set to ignore alerts and Libre isn’t clearing the Down status or something?

Here’s what I’m seeing:

My setup is

  • 1 Web Server
  • 1 Dedicated DB/Redis/rrdcached Server
  • 3 Distributed Pollers

Here is validate.php run on the web server

Component | Version
--------- | -------
LibreNMS  | 22.8.0
DB Schema | 2022_07_03_1947_add_app_data (244)
PHP       | 8.1.9
Python    | 3.9.2
Database  | MariaDB 10.5.15-MariaDB-0+deb11u1
RRDTool   | 1.7.2
SNMP      | 5.9

[OK]    Composer Version: 2.4.1
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Distributed Polling setting is enabled globally
[OK]    Connected to rrdcached
[OK]    Active pollers found
[OK]    Dispatcher Service is enabled
[OK]    Locks are functional
[OK]    Python wrapper cron entry is not present
[OK]    Redis is functional
[OK]    rrdtool version ok
[OK]    Connected to rrdcached

You can purge deleted ports from webui
can refer below cli tools to find orphan ports and delete

That’s part of the issue, none of the 51 ports show up as ‘Deleted’ ports (or Ignored or Disabled for that matter). I check for ports to be purged on at least a weekly basis, nothing new has showed up in there even with the 51 “Down” ports.
I don’t know how I’d use the CLI scripts since I don’t actually know which ports are counting against me here.

I’ve started digging into the libre database. So far, it looks like ports that are marked as “dormant” are what’s being counted towards my “Down” ports. I’m going completely off of simple logic, but that might make sense that these ports aren’t showing up in the Ports List page because their ‘ifOperStatus’ isn’t “down”, it’s “dormant”.

So far, how I’ve managed to get to numbers to decrease is by searching for ports in the dormant state, navigating to the device in the GUI, setting the dormant ports to Ignore Alerts, then rediscovering the device with the discovery script.

This seems like an oversight in some code somewhere.

Any additional input is appreciated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.