Global settings menu not working

Hello,

running LibreNMS for a couple years now, but since a while the global settings menu is broken.
Opening the global settings gives me the top bar and just @routes

The Chrome browser console shows the following error:
Uncaught ReferenceError: route is not defined
at Module.bUC5 (app.js?id=d074dd82ac08dba78c44:1)
at l (manifest.js?id=3c768977c2574a34506e:1)
at Object.0 (app.js?id=d074dd82ac08dba78c44:1)
at l (manifest.js?id=3c768977c2574a34506e:1)
at t (manifest.js?id=3c768977c2574a34506e:1)
at Array.r [as push] (manifest.js?id=3c768977c2574a34506e:1)
at app.js?id=d074dd82ac08dba78c44:1

Other users of the system have the same error.
Other browsers give me the same problem

====================================

Component Version
LibreNMS 1.58.1-48-ga1f4b1b88
DB Schema 2019_04_22_220000_update_route_table (147)
PHP 7.2.24-0ubuntu0.18.04.1
MySQL 10.1.43-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

1 Like

possibly related;
#Global settings - blank page after upgrade
#[SOLVED]Global Settings Page is Blank

try play around with your domain configuration in nginx / apache, and if base_url is apparent in /opt/librenms/config.php set it to just " / "

I tried changing my apache config, changed the hostname to the FQDN, to the hostname only, or even to an IP address, non if which solve this problem.
Also, this setup has been running for at least 3 years without this problem.
There is no base_url set in the config.php.
If I set base_url to “/” I still have the same problem.

base_url was commentant but even doing the configuration you suggested doesn’t work. would you have anything else to suggest? Thank you
Raffaelr

I seem to have the same issue.

Both editing httpd conf file and librenms conf file did not yield results.

It’s not the composer.

1 Like

I have th exact same problem! After upgrading my 1.56 install to 1.61 using FreeBSD port, I have also blank page of global config with @routes on it.

I also have this issue. Very strange.

I have the same issue here.

In my JS console, I see:

ReferenceError: Can't find variable: route bUC - app.js:1479

Validate follows:

[[email protected]:/usr/local/www/librenms] $ sudo ./validate.php 
PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /usr/local/www/librenms/includes/functions.php on line 1833

Deprecated: Array and string offset access syntax with curly braces is deprecated in /usr/local/www/librenms/includes/functions.php on line 1833
PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /usr/local/www/librenms/includes/functions.php on line 2336

Deprecated: Array and string offset access syntax with curly braces is deprecated in /usr/local/www/librenms/includes/functions.php on line 2336
sh: git: not found
sh: git: not found
====================================
Component | Version
--------- | -------
LibreNMS  | 1.61
DB Schema | 2020_02_10_223323_create_alert_location_map_table (159)
PHP       | 7.4.3
MySQL     | 5.7.29
RRDTool   | 1.7.2
SNMP      | NET-SNMP 5.7.3
====================================

[OK]    Installed from package; no Composer required
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  fping FAILURES can be ignored if running LibreNMS in a jail without ::1. You may want to test it manually: fping ::1
[FAIL]  fping could not be executed. fping must have CAP_NET_RAW capability (getcap) or suid. Selinux exlusions may be required.
 (This account is currently not available.)
[WARN]  fping FAILURES can be ignored if running LibreNMS in a jail without ::1. You may want to test it manually: fping ::1
[FAIL]  fping6 could not be executed. fping6 must have CAP_NET_RAW capability (getcap) or suid. Selinux exlusions may be required.
 (This account is currently not available.)
[[email protected]:/usr/local/www/librenms] $

This issue is over 3 months old. I went to open an issue at https://github.com/librenms/librenms/issues/new but “Please do not post bugs or ask questions or feature requests here

What else can we do without having access to our global settings?

This is fixed in release 1.63