Global settings menu not working

Hello,

running LibreNMS for a couple years now, but since a while the global settings menu is broken.
Opening the global settings gives me the top bar and just @routes

The Chrome browser console shows the following error:
Uncaught ReferenceError: route is not defined
at Module.bUC5 (app.js?id=d074dd82ac08dba78c44:1)
at l (manifest.js?id=3c768977c2574a34506e:1)
at Object.0 (app.js?id=d074dd82ac08dba78c44:1)
at l (manifest.js?id=3c768977c2574a34506e:1)
at t (manifest.js?id=3c768977c2574a34506e:1)
at Array.r [as push] (manifest.js?id=3c768977c2574a34506e:1)
at app.js?id=d074dd82ac08dba78c44:1

Other users of the system have the same error.
Other browsers give me the same problem

====================================

Component Version
LibreNMS 1.58.1-48-ga1f4b1b88
DB Schema 2019_04_22_220000_update_route_table (147)
PHP 7.2.24-0ubuntu0.18.04.1
MySQL 10.1.43-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

possibly related;
#Global settings - blank page after upgrade
#[SOLVED]Global Settings Page is Blank

try play around with your domain configuration in nginx / apache, and if base_url is apparent in /opt/librenms/config.php set it to just " / "

I tried changing my apache config, changed the hostname to the FQDN, to the hostname only, or even to an IP address, non if which solve this problem.
Also, this setup has been running for at least 3 years without this problem.
There is no base_url set in the config.php.
If I set base_url to “/” I still have the same problem.

base_url was commentant but even doing the configuration you suggested doesn’t work. would you have anything else to suggest? Thank you
Raffaelr

I seem to have the same issue.

Both editing httpd conf file and librenms conf file did not yield results.

It’s not the composer.