Graph issue after update

Hello I am getting font issue in historical graphs.
Attached the image for same. (

Can anyone please help me here

if you post screenshot here, it could more help.
I get only ads when following the link

I get similar error. Here is the error screenshot.graph-error

what says validate script in /opt/librenms ?

What @SourceDoctor means is:

Run ./validate.php and post the output

Here is my output after running ./validate.php


Could you specify precise where you get this error?
Where to go to, and what to do?

What platform do you use?

I have installed it on Centos 7, it was working fine initially, but after recent OS & Libre update the graph in traffic bill section stopped working.
The quick graph is working fine but others like Accurate Graphs | Transfer Graphs | Historical Graphs throw error. attached are the screenshots.

seems to be an issue due upgrading OS. You’ve upgraded all PHP parts to your running version? “fonts-dejavu-core” is installed? Have you upgraded freetype as is stands there?
On my system i’ve got libfreetype6 installed.
Is it a self compiled PHP Version, or does it come from distribution repository?

@SourceDoctor “fonts-dejavu-core” is installed, I had run yum update and updated everything. libfreetype6 is also installed. Self complied PHP 7.3.17.

-> self compiled PHP
i think that’s the point you’ve to search

I tried to rebuilt PHP again but no luck, switched to PHP 7.2 & 7.4 same issue. The issue is with only traffic bill graph all other graphs are working fine.

have you tried it with a PHP Version from the Distributor?

This seems to be related to a change in behavior of GD. The JPGraph library doesn’t expect that so throws an incorrect error.