Graph not visible in Wireless tab

The problem

On the wireless tab, the graphs shows an error. All other graphs from the device is drawn perfectly.
This seems to be an issue with LibreNMS as multiple vendor devices has the same issue (MikroTik and Unifi tested).

The error message is not very visible:


Output of ./validate.php

Component | Version
--------- | -------
LibreNMS  | 23.11.0 (2023-11-25T20:17:34+01:00)
DB Schema | 2023_11_04_125846_packages_increase_name_column_length (273)
PHP       | 8.1.22
Python    | 3.10.13
Database  | MariaDB 10.5.23-MariaDB-1:10.5.23+maria~ubu2004
RRDTool   | 1.7.2
SNMP      | 5.9.3

[OK]    Installed from the official Docker image; no Composer required
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service is enabled
[OK]    Locks are functional
[OK]    No python wrapper pollers found
[OK]    Redis is unavailable
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[OK]    rrd_dir is writable
[OK]    rrdtool version ok
[WARN]  Updates are managed through the official Docker image

What was the last working version of LibreNMS?

No response

Anything in the logs that might be useful for us?

No response

Related issue on Github: Graph not visible in Wireless tab · Issue #15761 · librenms/librenms · GitHub

You should probably click on one of the graphs and click show command to view the entire error message.

If I had to take a wild guess, it is a file permissions issue.

Thank you, I was not aware of this button!
Now I see the error message:

ERROR: opening '/data/rrd/': No such file or directory

Indeed looks like some permission error, but I don’t know why.
Permissions seems correct for all folders, also as I said, other types of graphs work correctly.
I checked and the folder is there, it has all the other rrd datafiles in it, but this one is not there actually

If I create the file manually and setting the correct ownership (librenms:librenms) I get a different error:

ERROR: mmaping file '/data/rrd/': Invalid argument

Any idea for this? I checked usual issues.

I still did not find the solution for the problem below

Problem was that Wireless module polling was disabled. After enabling, it works correctly.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.