Graphs are not continuous

Dear Community!

I have a problem with ALL of my LibreNMS devices, graphs are not continuous.
All of them look like this:

I looked at this similar issue report a few years ago:

However I was not able to find a solution to my problem.
Adjusted SNMP timeout, retry and max repeaters value, but I can’t spot any difference.
Poller performance also seems fine, no outstanding values.

Anyone has any clue?

Please check librenms.log for errors. Appears to be poller is not completing the poll with in specified time , default is 5 mins.

Thanks for helping me out, sorry for the late response.

In the librenms.log I can only see two error:

This one is quite frequent, I reported it in another thread:

/opt/librenms/poller.php 51 2023-08-14 20:30:14 - 1 devices polled in 15.68 secs
/opt/librenms/poller.php 10 2023-08-14 20:30:16 - 1 devices polled in 11.55 secs
[2023-08-14T20:30:25.191186+02:00] production.ERROR: Error polling sensors module for LibreNMS\Exceptions\InvalidRrdTypeException:  is not valid, must be: GAUGE | DERIVE | COUNTER | ABSOLUTE | DCOUNTER | DDERIVE in /opt/librenms/LibreNMS/RRD/RrdDefinition.php:122
Stack trace:
#0 /opt/librenms/LibreNMS/RRD/RrdDefinition.php(65): LibreNMS\RRD\RrdDefinition->checkType()
#1 /opt/librenms/includes/polling/ LibreNMS\RRD\RrdDefinition->addDataset()
#2 /opt/librenms/includes/polling/ record_sensor_data()
#3 /opt/librenms/includes/polling/ poll_sensor()
#4 /opt/librenms/includes/polling/ include('...')
#5 /opt/librenms/poller.php(126): poll_device()
#6 {main}
[2023-08-14T20:30:25.201219+02:00] production.ERROR:  is not valid, must be: GAUGE | DERIVE | COUNTER | ABSOLUTE | DCOUNTER | DDERIVE {"exception":"[object] (LibreNMS\\Exceptions\\InvalidRrdTypeException(code: 0):  is not valid, must be: GAUGE | DERIVE | COUNTER | ABSOLUTE | DCOUNTER | DDERIVE at /opt/librenms/LibreNMS/RRD/RrdDefinition.php:122)"}

The other one is less frequent:

/opt/librenms/discovery.php 60 2023-08-14 20:01:13 - 1 devices discovered in 17.81 secs
/opt/librenms/discovery.php 55 2023-08-14 20:01:14 - 1 devices discovered in 21.47 secs
/opt/librenms/discovery.php 56 2023-08-14 20:01:15 - 1 devices discovered in 21.27 secs
[2023-08-14T20:01:16.436511+02:00] production.ERROR: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'rrd_type' in 'field list' (SQL: INSERT IGNORE INTO `wireless_sensors` (`sensor_class`,`device_id`,`sensor_oids`,`sensor_index`,`sensor_type`,`sensor_descr`,`sensor_divisor`,`sensor_multiplier`,`sensor_aggregator`,`sensor_limit`,`sensor_limit_warn`,`sensor_limit_low`,`sensor_limit_low_warn`,`sensor_current`,`entPhysicalIndex`,`entPhysicalIndex_measured`,`rrd_type`,`access_point_id`)  VALUES (sinr,61,["."],5,routeros,lte1: Signal SINR,1,1,sum,NULL,NULL,NULL,NULL,-2,NULL,NULL,GAUGE,NULL)) (SQL: INSERT IGNORE INTO `wireless_sensors` (`sensor_class`,`device_id`,`sensor_oids`,`sensor_index`,`sensor_type`,`sensor_descr`,`sensor_divisor`,`sensor_multiplier`,`sensor_aggregator`,`sensor_limit`,`sensor_limit_warn`,`sensor_limit_low`,`sensor_limit_low_warn`,`sensor_current`,`entPhysicalIndex`,`entPhysicalIndex_measured`,`rrd_type`,`access_point_id`)  VALUES (sinr,61,["."],5,routeros,lte1: Signal SINR,1,1,sum,NULL,NULL,NULL,NULL,-2,NULL,NULL,GAUGE,NULL))#0 /opt/librenms/LibreNMS/Device/Sensor.php(170): dbInsert()
#1 /opt/librenms/LibreNMS/Device/Sensor.php(558): LibreNMS\Device\Sensor->save()
#2 /opt/librenms/LibreNMS/Device/Sensor.php(475): LibreNMS\Device\Sensor::sync()
#3 /opt/librenms/LibreNMS/Device/WirelessSensor.php(116): LibreNMS\Device\Sensor::discoverType()
#4 /opt/librenms/includes/discovery/ LibreNMS\Device\WirelessSensor::runDiscovery()
#5 /opt/librenms/includes/discovery/ include('...')
#6 /opt/librenms/discovery.php(106): discover_device()
#7 {main}

Validate does not show any database schema problem.

The only weird thing I found is that validate shows LibreNMS version 22.7.0, though I’m using Docker latest version which should be 23.5.0

Why it is not correct?

Also, all sensor show “No data”:

I have tried increasing the pollers based on this post:

I have devices which last poll time is always 10 minutes old… But I don’t understand why, I don’t have that much device (55 in total - I saw other with 900+ devices…). Also increasing poller workers did not helped, no changes

This was solved, basically poller frequency was changed (I did not change it) and it is only visible in the UI after toggling “Advanced”…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.