Help with Unpolled devices Warning

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hi,
I am getting always the unpolled devices warning but if I go to Poller -> history, all the devices have been polled within 10 minutes and none of them lasts more than 50seconds polling.

I have verified that system time and mysql time are same.
Php has also the correct timezone.

Here is the validate.php output:

Component Version
LibreNMS 1.53.1-14-gcfaf913
DB Schema 2019_05_30_225937_device_groups_rewrite (135)
PHP 7.2.14
MySQL 5.5.60-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.8.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
[FIX]:
Check your poll log and see: http://docs.librenms.org/Support/Performance/
Devices:
ssw02020008.X
kar77460002.X
kro76490001.X
kar78620001.X
ksw74350002.X
kar78490004.X
kar77520001.X
sro22810001.X
sar01850002.X
sar02130001.X

If I go to the polling history of one of this devices, shows that polling time takes 2.5seconds and las polling has been 8 minutes ago.

What am I doing wrong?

Polling has to complete in less than 5 min

warning says 15 min

imagen

That’s not usual polling time setup. Did you make that?

The warning doesn’t fire until they have missed 3 intervals or something like that.

No, this is my cron configuration:

Using this cron file requires an additional user on your system, please see install docs.

#33 */6 * * * librenms /opt/librenms/discovery.php -h all >> /dev/null 2>&1
/5 * * * * librenms /opt/librenms/discovery.php -h new >> /dev/null 2>&1
/5 * * * * librenms /opt/librenms/cronic /opt/librenms/poller-wrapper.py 6
15 0 * * * librenms /opt/librenms/daily.sh >> /dev/null 2>&1
#
* * * * librenms /opt/librenms/alerts.php >> /dev/null 2>&1
#
/5 * * * * librenms /opt/librenms/poll-billing.php >> /dev/null 2>&1
#01 * * * * librenms /opt/librenms/billing-calculate.php >> /dev/null 2>&1
*/5 * * * * librenms /opt/librenms/check-services.php >> /dev/null 2>&1
33 */6 * * * librenms /opt/librenms/cronic /opt/librenms/discovery-wrapper.py 1

The poller is configured to run every 5 minutes.

How could I verify that? In Poller -> History-> Log all the polling time are below 50seconds and las polled time are no older than 10 minutes.
I am thinking to increase poller threads from 6 to 10/12 to see if this solves the issue… What do you think?
Our server has 12GB Ram and 8vcpu

10 minutes is too long, it should be < 5 minutes.

I have increased to 12, the poller threads in the cron file but I am still getting the unpolled warning.
None of the poller times is higher than 30seconds. I do not know what else to do to decrease the poller time.
Any advice?

I’ve been getting the same message for probably a couple months now too. I don’t log into LibreNMS very often, so I haven’t looked at fixing it.

My setup is similar. 28 total devices polled. Longest device polled sits around 15 seconds. About 30-35 seconds total for polling every 5 minutes. Whenever I go into polling history, they’ve all been polled within the last 5 minutes. The message still says some devices haven’t completed within the last 15 minutes.

I have increased pollers threads to 16. Does this graph means the total time taken to poll all the devices?

The highest value is 269 seconds. I am still getting the unpolled warning. Any advice?
Thanks in advance

You should set the discovery interval to much less than every 5 min, then you will also have more threads for the poller to work with. Normally discovery runs every 6h.

1 Like

Exactly if you have set discovery to run at the same time As your poller runs that Is going to cause major issues. I highly recommend you change the discovery back to every 6 hours.

1 Like

This discover interlval only applies to new added devices isn´t it? I think that is the default configuration.

The discovery process that runs every 6 hours I have disabled.

Yep, the -h new discovery only takes care of the new devices, so it should not harm.

I haven’t changed my cron at all. Using the stock /opt/librenms/librenms.nonroot.cron file.

Any advise? Still getting same error…
Could it be disabled the message error?

Check in the poller logs if you have entries in the unpolled devices, if yes, click on one of those devices, go to the gear icon and choose capture, then choose poller and run it from there and check the output.

I show no unpolled devices under my logs, even though the warning is flashing at the same time.

Odd, no clue what is triggering it then.