Graphs Not Populating After Distributed Polling Setup

I know I’m using double polling, because only that’s making the graphs.

I have 3 questions :-

  1. where does the logs of systemctl status librenms.service really go ? I see entry only /opt/librenms/logs/librenms.log… When I’m polling using this service, no logs appear in poller-wrapper, which is understsood, but how can i manage my polling using this service. I’m not enjoying this service much really? :frowning:

  2. Does rrdcached need to be enabled on both primary and secondary pollers ?

  3. Why are some logs showing memcached related stuff, since I’m only using redis-server.

root@SYAP04A:~/mahesh$ su - librenms
librenms@SYAP04A:~$ ./validate.php

Component Version
LibreNMS 24.1.0-101-g00f06c0cf (2024-02-26T21:03:42+01:00)
DB Schema 2024_02_07_151845_custom_map_additions (290)
PHP 8.1.2-1ubuntu2.14
Python 3.10.12
Database MariaDB 10.6.16-MariaDB-0ubuntu0.22.04.1
RRDTool 1.7.2
SNMP 5.9.1

[OK] Composer Version: 2.7.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Distributed Polling setting is enabled globally
[OK] Connected to rrdcached
[FAIL] Both Dispatcher Service and Python Wrapper were active recently, this could cause double polling
[OK] Dispatcher Service is enabled
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is functional
[OK] rrdtool version ok
[OK] Connected to rrdcached

Not sure about your systemctl stuff as I don’t use it but perhaps → systemd - How to see full log from systemctl status service? - Unix & Linux Stack Exchange

The RRD files need to be in one place – it could be one of the pollers, or if you have a web-only front end, or a completely different/seperate hosts.

This host needs rrdcached setup, and every other instance of LibreNMS needs to be configured to use that.

$config[‘rrdcached’] = ‘your-rrdcached-host:42217’;

As for memcached perhaps you have some configuration on one of the devices?