Graylog integration not working

I need a little help troubleshooting why my graylog integrations doesnt show anything.

i’ve put following in the config:

$config['graylog']['server']   = 'http://172.16.65.200';
$config['graylog']['port']     = '129000';
$config['graylog']['username'] = 'librenms';
$config['graylog']['password'] = '*******';

without any luck. i’ve tried with my port 9000 also (i dont proxy it to 80).
is there any logs or anything with can help me on track to get it working?

Is your Graylog user an admin? This is required. Also, if you are using https, that probably should be part of the URL; i.e., ‘https://172.16.65.200’.

1 Like

Also double check this is the actual port you are using on GrayLog. I think it defaults to 9000 and you need to specify the version.

https://docs.librenms.org/#Extensions/Graylog/

no its not, i will try that! its internal in the datacenter and their segmented, so its just a http.

its set to 9000 as in the graylog config

129000 is the api port…

tried it all, admin user, version 2.1 (documetation states that version should be used if older than 2.1 and im on 2.3.2).

still nothing…

when changing the config, do i need to restart libre?

No, its PHP any change happens right away.

thought so :confused:

firewall setting on the server perhaps?

none, i can access the ports without any problems

here is what I have image

tried this
$config[‘graylog’][‘server’] = ‘http://172.16.65.200’;
$config[‘graylog’][‘port’] = 9000;
$config[‘graylog’][‘username’] = ‘librenms’;
$config[‘graylog’][‘password’] = ‘*******’;
$config[‘graylog’][‘version’] = ‘2.3.2’;

no luck

also tried with the base_uri

129000 is an order of magnitude too high!
12900 is the API port

tried with 12900 without any luck…

somewhat a place where i am in doubt is that from version 2.1 and onwards the base_uri is /api/
bu ti cant find anything about this anywhere?

What version are you actually running?