Help with add new os

Hi everyone,

I try since a week to add a new OS support in LibreNMS for switches Qtech.
Indeed, I can add the Qtech in LibreNMS but they are class as Generic Device and poll none information.
I try to follow the tutorial here : 40 but it still not working.
I create a file qtech.yaml in /include/definition and an other file in /polling/os but all the qtech are still as generic devices.
I rediscover the device with discover.php et poller.php but no information are poll.

health (processor,memory) still not graphs
I take this mib’s/Qtech_private_2.1.26.mib

Thanks for your help.

mibs are not declared that way.

mib: Qtech_private_2.1.26.mib

should be:


As declared at the begining of your .mib file

Thx for reply.
I just rename mib file like “QTECH-MIB” and declare like you said, rediscovered and pollered device.
But still processor and memory not graph.

Ok. Where did you put the mib? In /opt/librenms/mibs or /opt/librenms/mibs/qtech?

What if you snmpwalk that oid? Does it return processors?

Creating a Pull request including an snmprec as described in the docs will allow us to give you feedback. You can label it WIP so we know you are working on it

I download mibs from’s/QSW-2800Rev.F1,%202870/ (all),
rename them like “LLDP-MIB.mib” to “LLDP-MIB” and put them in /usr/share/snmp/ and /opt/librenms/mibs/qtech/
And it’s work!
Thank you.

Murrat, i don’t know how create a pull request :weary:

1 Like