Help with Big switch and loading mibs. I cannot find anything related to big switch and librenms

When asking for help and support, please provide as much information as possible. This should include:

  • Steps to reproduce an issue.
  • The output of ./validate.php

If it’s an issue with the WebUI then please consider including the browser version you are using.

If you need to post any text longer than a few lines, please use a pastebin service such as https://p.libren.ms using non-expiring pastes.

[email protected]:/opt/librenms# ./validate.php

Component Version
LibreNMS 1.31.03-31-gb18c41b
DB Schema 206
PHP 7.0.22-0ubuntu0.16.04.1
MySQL 10.0.31-MariaDB-0ubuntu0.16.04.2
RRDTool 1.5.5
SNMP NET-SNMP 5.7.3

====================================

[OK] Database connection successful
[OK] Database schema correct

I have the mibs for the bigswitch
it is composed of leafs and spines. We use HP swithes for this.

Hi,

Is this being discovered as a Generic device?

No it is being discovered as a big switch but I would like to get it to use the mibs that I have from Bigswitch. I’m having trouble with a couple of items.
How do I tell snmptranslate that there is a new file to look at?
How do i get a list of “You will then need to create a list of the OIDs you wish to use in the OS definition.”?

Big Cloud Fabric Appliance 3.6.0 (bcf-3.6.0 #150)
System Name artotxlpc02-bsfd-bc
IP Address 10.84.17.2
Operating System Bigswitch
Object ID enterprises.37538.1
Contact SNMP USER
Location SNMP CONFIG
Uptime 315 days, 21h 15m 33s

kc3scuba

from the cli can you run ./discovery.php -h <hostname or ip> and pastebin the output

[email protected]:/opt/librenms# ./discovery.php -h 10.84.17.2
LibreNMS Discovery
10.84.17.2 47 test-os

Load disco module os

Runtime for discovery module ‘os’: 0.1500 seconds with 840 bytes

Unload disco module os

Load disco module ports

Runtime for discovery module ‘ports’: 0.0550 seconds with 2184 bytes

Unload disco module ports

Load disco module ports-stack

Runtime for discovery module ‘ports-stack’: 0.0080 seconds with 640 bytes

Unload disco module ports-stack

Load disco module entity-physical

Caching OIDs: entPhysicalEntry entAliasMappingIdentifier…

Runtime for discovery module ‘entity-physical’: 0.5990 seconds with 4328 bytes

Unload disco module entity-physical

Load disco module processors

hrDevice: …

Runtime for discovery module ‘processors’: 0.6560 seconds with 46768 bytes

Unload disco module processors

Load disco module mempools

hrStorage : …

Runtime for discovery module ‘mempools’: 0.1390 seconds with 25832 bytes

Unload disco module mempools

Load disco module cisco-vrf-lite

Runtime for discovery module ‘cisco-vrf-lite’: 0.0000 seconds with 1592 bytes

Unload disco module cisco-vrf-lite

Module [ cisco-mac-accounting ] disabled globally.

Module [ cisco-pw ] disabled globally.

Module [ cisco-vrf ] disabled globally.

Module [ cisco-cef ] disabled globally.

Module [ cisco-sla ] disabled globally.

Module [ cisco-cbqos ] disabled globally.

Module [ cisco-otv ] disabled globally.

Load disco module ipv4-addresses

s.s.s.s.

Runtime for discovery module ‘ipv4-addresses’: 0.3080 seconds with 31136 bytes

Unload disco module ipv4-addresses

Load disco module ipv6-addresses

Runtime for discovery module ‘ipv6-addresses’: 0.1690 seconds with 17592 bytes

Unload disco module ipv6-addresses

Module [ route ] disabled globally.

Load disco module sensors

ENTITY-SENSOR: Caching OIDs: entPhysicalDescr entPhysicalName entPhySensorType entPhySensorScale entPhySensorPrecision entPhySensorValue…
Airflow:
Current:
Charge:
Dbm:
Fanspeed:
Frequency:
Humidity:
Load:
Power:
Runtime:
Signal:
State:
Temperature:
Voltage:
Snr:

Runtime for discovery module ‘sensors’: 1.2400 seconds with 73208 bytes

Unload disco module sensors

Load disco module storage

hrStorage : …

Runtime for discovery module ‘storage’: 0.3700 seconds with 7536 bytes

Unload disco module storage

Load disco module hr-device

Runtime for discovery module ‘hr-device’: 0.7380 seconds with 30304 bytes

Unload disco module hr-device

Load disco module discovery-protocols

CISCO-CDP-MIB: LLDP-MIB: OSPF Discovery: enabled

Runtime for discovery module ‘discovery-protocols’: 0.0630 seconds with 8568 bytes

Unload disco module discovery-protocols

Load disco module arp-table

eth0:

eth1:

eth2:
.

Runtime for discovery module ‘arp-table’: 0.0530 seconds with 45688 bytes

Unload disco module arp-table

Module [ discovery-arp ] disabled globally.

Module [ junose-atm-vp ] disabled globally.

Load disco module bgp-peers

No BGP on host

Runtime for discovery module ‘bgp-peers’: 0.0100 seconds with 2672 bytes

Unload disco module bgp-peers

Load disco module vlans

IEEE8021-Q-BRIDGE-MIB VLANs:

Runtime for discovery module ‘vlans’: 0.0460 seconds with 4456 bytes

Unload disco module vlans

Module [ vmware-vminfo ] disabled globally.

Module [ libvirt-vminfo ] disabled globally.

Module [ toner ] disabled globally.

Load disco module ucd-diskio

Runtime for discovery module ‘ucd-diskio’: 0.0390 seconds with 54656 bytes

Unload disco module ucd-diskio

Module [ applications ] disabled globally.

Load disco module services

Runtime for discovery module ‘services’: 0.0000 seconds with 352 bytes

Unload disco module services

Load disco module stp

Runtime for discovery module ‘stp’: 0.0130 seconds with 3648 bytes

Unload disco module stp

Load disco module ntp

Runtime for discovery module ‘ntp’: 0.0000 seconds with 144 bytes

Unload disco module ntp

Module [ loadbalancers ] disabled globally.

Module [ mef ] disabled globally.

Load disco module wireless

Runtime for discovery module ‘wireless’: 0.0080 seconds with 132808 bytes

Unload disco module wireless

Load disco module fdb-table

Runtime for discovery module ‘fdb-table’: 0.0430 seconds with 1016 bytes

Unload disco module fdb-table

Discovered in 5.162 seconds

SNMP: Get[19/0.28s] Walk [28/1.69s]
MySQL: Cell[122/0.09s] Row[22/-0.02s] Rows[55/0.03s] Column[1/0.00s] Update[92/2.30s] Insert[2/0.05s] Delete[0/0.00s]

So it was discovered as a generic device? and looks like you used the script to make the new discovery of the device correct?

When I run this from the Web gui via the capture window it seems to work some what but still not using the mibs they have
. the output is very big

I have tried both CLI and the webgui. I also turn on the mibs for just this device

That’s not how you add support for a New Device…

You may want to submit the issue in git hub with all required info asking for Add support for New Device.

Github issues

Or you can code it yourself and make a pull request.

https://docs.librenms.org/Developing/os/Initial-Detection/