Hostname with point "." character : possible bug

Hi everybody,
I noticed that when hostname “sysname” contains a point “.” he is not displayed in full in webui in some pages like “alerts” or “availability map” for example.
Example : when sysname is “ASR1001-1.XXX”, Webui display just “ASR1001-1”.
I don’t know if this issue is appeared recently because it’s the first time i’ve used a name like this.
Do you think that a fix can be made ?

Periods are separators for domain names. What you are saying is that host “ASR1001-1” is part of domain “XXX”.

In short, you cannot use a period in an unqualified hostname as you have done. Suggest you use “ASR1001-1-XXX” instead.

1 Like

Ok thank you for your answer. I know this but i thought there was a trick to avoid this behavior.
Have a nice day.

1 Like

I kept looking for a solution and when i increase ‘shorthost_target_length’ it’s work, despite “.” :slight_smile:
I had seen this option but didn’t think it would work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.