How does one avoid "INFO: device:poll" entries in librenms.log?

Hi,

this is more of an “in principle” question:
How does one avoid “INFO: device:poll” entries in librenms.log?

I’m running librenms 24.5.0 in containers (official ones, “latest”) on a raspi, including dispatcher as sidecar and rrdcache - works like a charm.

When trying to minimise logging I stumbled upon a problem I couldn’t solve - I could not get rid of the “INFO: device:poll” messages in librenms.log.
I have a workaround in place so all good, but still interested in learning what I did wrong.

I tried by

  • setting service_loglevel → WARNING - no joy.
  • changing various .php and .py source code files in containers - no joy.

I am obviously missing something and it drives me nuts :slight_smile:
Any pointers to where I find how this is done properly and/or what I could try to trace this further would be much appreciated.

Just found the place where it happens.

File: LibreNMS/Poller.php
Line 133

Log::channel('single')->alert(sprintf('INFO: device:poll %s (%s) polled in %0.3fs',
$this->device->hostname,
$this->device->device_id,
$measurement->getDuration()));

Commenting this out gets rid of the log entries. Not sure if this extra log is intentional, just happy to have found it… this was driving me crazy :slight_smile: