Http 500 error (NGINX)

I get “HTTP 500 error” when trying to access LibreNMS…

It looks like its running twice ?

[email protected]:/opt/librenms# ps aux | grep php-fpm
root 613 0.0 0.4 229292 10096 ? Ss Jul03 0:48 php-fpm: master process (/etc/php/8.0/fpm/php-fpm.conf)
www-data 707 0.0 0.3 229576 7056 ? S Jul03 0:00 php-fpm: pool www
www-data 708 0.0 0.3 229576 7056 ? S Jul03 0:00 php-fpm: pool www
root 22299 0.0 0.4 231976 9840 ? Ss Jul03 0:50 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
librenms 22301 0.0 0.3 232412 7852 ? S Jul03 0:00 php-fpm: pool librenms
librenms 22302 0.0 0.4 232412 9952 ? S Jul03 0:00 php-fpm: pool librenms
root 28501 0.0 0.0 6208 816 pts/0 S+ 11:31 0:00 grep php-fpm

Also issues with upgrading NGINX…

[email protected]:~# apt list --upgradable
Listing… Done
nginx/stable 1.21.1-1~buster all [upgradable from: 1.14.2-2+deb10u4]
N: There are 23 additional versions. Please use the ‘-a’ switch to see them.

$ ./validate.php

Component Version
LibreNMS 21.7.0-14-g578602f8f
DB Schema 2021_25_01_0127_create_isis_adjacencies_table (211)
PHP 7.4.21
Python 3.8.3
MySQL 10.5.11-MariaDB-1:10.5.11+maria~buster
RRDTool 1.7.1
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 2.1.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

You look to have 7.4 and 8.0 fpm configured - maybe they are fighting over the same socket. Remove the config from 8.0 and see if that gets it going.

I renamed /etc/php/8.0/fpm/php-fpm.conf to /etc/php/8.0/fpm/php-fpm.conf.old

Still the same “HTTP error 500”.

I have looked at configuration. I have this line in /etc/nginx/sites-enabled/librenms.vhost:

fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;

but in /var/run/php/ I only have this file: php7.4-fpm.pid ?

:slight_smile: Jens

I did fix the missing /var/run/php/php7.4-fpm.sock; file missing.

[email protected]:/var/run/php# ps aux | grep php-fpm
root 13814 0.0 1.3 231976 27144 ? Ss 12:49 0:00 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
librenms 13815 0.0 0.5 232260 10904 ? S 12:49 0:00 php-fpm: pool librenms
librenms 13816 0.0 0.7 232412 14656 ? S 12:49 0:00 php-fpm: pool librenms
root 26405 0.0 0.0 6208 764 pts/0 S+ 12:57 0:00 grep php-fpm

But still it seems like its running 2 instances ?

And I still have “HTTP error 500”…

Check what your webserver logs says.
These configuration steps are covered by the installation guide Install LibreNMS - LibreNMS Docs

Thanks…

It was memory_limit in PHP.ini file…

Now my LibreNMS is running :slight_smile: