HTTP ERROR 500 after 22.5.0 update [SOLVED]

Some FYI I hope helps anyone who hits this for a PHP FPM error which killed me after 22.5.0 updated and left my web UI with a 500 error.

In my case it was FPM 7.3 getting hung up about something, so I forced 7.4 and it came good.

composer is on 1.6.3-1 and most recent for Ubuntu 18.04.4 LTS

Quite an old install and was obviously scared or too lazy to moved to PHP 7.4 at some point in the past, so stayed on 7.3. The error in logs/error_log was:

2022/05/22 10:24:49 [error] 27268#27268: *8 FastCGI sent in stderr: “PHP message: PHP Warning: require(/opt/librenms/vendor/composer/…/symfony/polyfill-php80/bootstrap.php): failed to open stream: Permission denied in /opt/librenms/vendor/composer/autoload_real.php on line 55PHP message: PHP Fatal error: require(): Failed opening required ‘/opt/librenms/vendor/composer/…/symfony/polyfill-php80/bootstrap.php’ (include_path=’.:/usr/share/php’) in /opt/librenms/vendor/composer/autoload_real.php on line 55” while reading response header from upstream, client: y.y.y.y, server: x.x.x.x, request: “GET / HTTP/2.0”, upstream: “fastcgi://unix:/var/run/php/php7.3-fpm.sock:”, host: “x.x.x.x”

To fix things I tried:

  • ./validate - all clean
  • ran ./ again - no errors, no change
  • ./scripts/composer_wrapper.php install --no-scripts - no errors, no change
  • ran the installer permissions lines again (Installing LibreNMS - LibreNMS Docs - Set Permissions section) - no change
  • wiped out ./composer and went again from the top - no change

So back to the install doco and simple fix - but non-obvious from the error:

  1. pasted the entire apt lines from doco including PHP 7.4 - it updated PHP and mariadb components only
  2. configured fpm as per doco
  3. systemctl disable php7.3-fpm
  4. systemctl unmask php7.4-fpm
  5. systemctl enble php7.4-fpm
  6. systemctl start php7.4-fpm

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.