Http://librenms.example.com/install.php doesn't load after fresh install

Hello,

I just completed the steps for a fresh install using CentOS 7 / Apache.

When I go to the example webpage listed in the title , the page doesn’t load. I get “This site can’t be reached”

I know I screwed up at configuring apache:
Messed up the line:
“ServerName librenms.example.com
(I tried to name this something else. Have gone back and fixed this line, and restarted the server. Still doesn’t load.)

I can see apache running when I do top.

When running validate.php I get this error:
[FAIL] config.php does not exist, please copy config.php.default to config.php
[[email protected] librenms]$ sudo chown librenms:librenms /opt/librenms/config.php

But when I try the command:
chown librenms:librenms /opt/librenms/config.php

I get the following:
chown: cannot access ‘/opt/librenms/config.php’: No such file or directory

(My understanding is I need to get this example.com web interface up first so I can copy text out of there for config.php)

Can anyone tell me what things to check? Thanks in advance!

First of all, the file config.php doesn’t exist on your server. Check out the docs were the creation is described.

For the server name you can use the IP address of your server.
But I would suggest to get a little more used to Linux and Apache basics before continuing.

1 Like

Hi Jarod,

Yes, it says to create a config.php and copy text from this web page, which I can’t get loaded, so stuck on getting that page to load before I can create this file.

"The web installer might prompt you to create a config.php file in your librenms install location manually, copying the content displayed on-screen to the file. "

Thanks for your hep!

Ryan

So you even don’t see the installer pages where it guides you through the installation?