HTTP timed out and database structure may be inconsistent error

I’m trying to set up my first install of LibreNMS and I keep getting the error “HTTP request timed out, your database structure may be inconsistent” during the “Build Database” step. I have gotten the same results when I tried to set it up stand-alone and when I try connecting a separate database server. I’ve seen two mentions of this problem on this site, but neither had a solution (one person was able to get it to work after trying 4 or 5 times and the other didn’t have a solution that I saw). I have tried several times and I keep getting this error. Is there anyway to lengthen the timeout (my machine isn’t very fast) or is there a script that I can run manually hat doesn’t require going through a website to build the database?
Web page error:

validate.php result:

Component Version
LibreNMS 24.2.0-33-gf6d67c1cd (2024-03-25T12:17:53-04:00)
DB Schema Not Connected (0)
PHP 8.2.7
Python 3.11.2
Database Not Connected
RRDTool 1.7.2
SNMP 5.9.3

[OK] Composer Version: 2.7.2
[OK] Dependencies up-to-date.
Could not connect to database, check logs/librenms.log.

Update: I’m still having the problem in both Chrome and Edge. However, the problem MAY be on the client side. I logged info from nginx and saw the following:
2024/03/30 21:57:42 [info] 1178#1178: *3 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too while reading upstream, client:, server: xxxx, request: “GET /install/ajax/database/migreate HTTP/1.1”, upstream: “fastcgi://unix:/run/php-fpm-librenms.sock:”, host: “”, referrer: “http://xxxxxx/install.database

Still no dice - tried Firefox on both Windows 11 and Debian Bookworm. Everything timing out after 5 minutes.

I got it to work, though not through the web installer. I got everything set up until the Web installer. However, before running in the installer, I ran the SQL script from librenms/database/schema/mysql-schema.sql at master · librenms/librenms · GitHub. After running that script, did the Web install step and things worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.