Huawei Switch : FDB table empty when sticky MAC

Hi everybody,

I have a problem when i want to list the FDB Table on Huawei Switch.
If mac address are learning dynamically i’m not have problem and find mac adresses in “FDB Table” menu.

But if i use “port-security mac-address sticky” on my switch, mac address are in “Sticky” type (not in “dynamic”) and mac address are not present in “FDB Table” menu.

I think “LibreNMS” doesn’t understand “sticky” type of mac-address.

Bonjour Olivier,
Could you check that the value is provided by the switch in SNMP replies ?

I don’t know but in CLI when i run “display mac-address” the type of mac address is not “dynamic” but “sticky”.
How can i know snmp request send by LibreNMS to obtain FDB Entries ?

Easiest way is to ask Huawei support. Second way is to get the complete SNMP tree of your device, and search for the mac address you are interested in. If you get a single ligne with it, just post it here.

snmpwalk -v2c -c <community> -m all -M mibs:mibs/huawei <IP>  .   > fileReply.txt
cat fileReply.txt | grep -i 02 26 97 09 F4 42
cat fileReply.txt | grep -i 02:26:97:09:F4:42
cat fileReply.txt | grep -i 2:26:97:9:F4:42

This is for Mac address in “Sticky” mode :
BRIDGE-MIB::dot1dTpFdbAddress.‘tM(’.8’ = STRING: 74:4d:28:27:c9:38

And it’s same result for Mac Address in Dynamic mode…

So there I see no reason not to see the sticky mac in the FDB table. You can check the FDB code in LibreNMS to understand if there is a reason there.

I’m not developer so i can’t check the FDB code sorry :frowning:
I try to start manualy discovery.php script and i see this :

Load disco module fdb-table

SNMP[[0;36m’/usr/bin/snmpbulkwalk’ ‘-v2c’ ‘-c’ ‘COMMUNITY’ ‘-OQUsetX’ ‘-m’ ‘HUAWEI-L2MAM-MIB’ ‘-M’ ‘/opt/librenms/mibs:/opt/librenms/mibs/huawei’ ‘udp:HOSTNAME:161’ ‘hwDynFdbPort’[0m]

I think fdb-table module used mib for dynamic mac address only.