I don't understand how to use rrdstep.php

I am trying to follow the instructions at 1 Minute Polling - LibreNMS Docs to switch over from the default 5-minute polling to 1-minute polling. This seems to amount to:

  1. going to server’s “/settings/poller/rrdtool/” and changing the “300” to “60”, and “600” to “120”
  2. editing /etc/cron.d/librenms and changing the entry with " poller-wrapper.py" from “/5" to "/1” (or well, to just “*”); and “service cron reload” to update
  3. running “rrdstep.php” to convert the old rrd files

But… the docs seem to be lacking. As directed, it says to " ./scripts/rrdstep.php -h localhost", but that just results in … nothing happening:

root@librenms:/opt/librenms# ./scripts/rrdstep.php -h localhost
Converted: 0 Failed: 0 Skipped: 0

I don’t know what I’m missing.

Now, while I’m here, the boss also wants me to extend the graphing data so that it will retain 3 years of information. But again, the librenms documentation is being quite unhelpful in helping me figure out specifically which numbers to use where, and how to then update the old already-created rrd files.

Note that for this pair of conversions, I’ve been using a default installation of librenms that has been polling every five minutes, with these values:

RRD Format Settings: RRA:AVERAGE:0.5:1:2016 RRA:AVERAGE:0.5:6:1440 RRA:AVERAGE:0.5:24:1440 RRA:AVERAGE:0.5:288:1440 RRA:MIN:0.5:1:2016 RRA:MIN:0.5:6:1440 RRA:MIN:0.5:24:1440 RRA:MIN:0.5:288:1440 RRA:MAX:0.5:1:2016 RRA:MAX:0.5:6:1440 RRA:MAX:0.5:24:1440 RRA:MAX:0.5:288:1440 RRA:LAST:0.5:1:2016

run it like this


what happens?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.