I m unable to update

Hi i m trying to update my version. but i have the following problem
i run daily.sh and i got the message
Updating to latest release FAIL
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK

then i m trying the manual update and i have the folliwing messages

remote: Enumerating objects: 1379, done.
remote: Counting objects: 100% (1379/1379), done.
remote: Compressing objects: 100% (61/61), done.
remote: Total 1957 (delta 1333), reused 1348 (delta 1318), pack-reused 578
Receiving objects: 100% (1957/1957), 2.53 MiB | 0 bytes/s, done.
Resolving deltas: 100% (1535/1535), completed with 988 local objects.
From https://github.com/librenms/librenms

  • [new branch] 1.29 -> origin/1.29

  • [new branch] 1.30 -> origin/1.30

  • [new branch] 1.30.01 -> origin/1.30.01

  • [new branch] 1.31 -> origin/1.31

  • [new branch] 1.32 -> origin/1.32

  • [new branch] 1.32.01 -> origin/1.32.01

  • [new branch] 1.33 -> origin/1.33

  • [new branch] 1.34 -> origin/1.34

  • [new branch] 1.35 -> origin/1.35

  • [new branch] 1.36 -> origin/1.36

  • [new branch] 1.43 -> origin/1.43

  • [new branch] 1_50 -> origin/1_50

  • [new branch] 1_62 -> origin/1_62

  • [new branch] 1_65 -> origin/1_65

  • [new branch] gh-pages -> origin/gh-pages
    6a79d44…422d119 master -> origin/master

  • [new branch] php53 -> origin/php53

  • [new branch] php56 -> origin/php56

  • [new branch] php71-python2 -> origin/php71-python2

  • [new branch] php72 -> origin/php72

  • [new branch] phpunit/testdox -> origin/phpunit/testdox
    You are not currently on a branch. Please specify which
    branch you want to merge with. See git-pull(1) for details.

    git pull

Here is the output of validate.php

Component Version
LibreNMS 967fb8009235a1b17808aec86ab4a90c17aeb66b
DB Schema 195
PHP 7.0.33
MySQL 5.5.68-MariaDB
RRDTool 1.4.8


[OK] Database connection successful
[FAIL] MySQL Database collation is wrong: utf8 utf8_general_ci [FIX] https://t.libren.ms/-zdwk
[OK] Database schema correct
[WARN] Your local git branch is not master, this will prevent automatic updates.
[WARN] Your local git contains modified files, this could prevent automatic updates.
Modified files:


  • If you can, do a snapshot first :slight_smile:
  • git checkout includes/init.php
    – this will restore the file to the official one and override whatever change was done in it
  • git checkout master
    – to force the master branch
  • ./daily.sh
  • ./daily.sh a second time
  • ./validate.php

Let see how far it goes.

Thansk for your reply

i ran succesfullt the two first command
but when i run daily.sh
I got the following messages.
output of daily.sh

perhaps i should update to php7.3?

PHP 7.4 would be better, will give you some time until next upgrade.

i have installed php7.4
from this documetation
i needed to install two other packages
php74-php-pear.noarch php-pear-Net-IPv4.noarch
and now the two daily.sh seems to work
but here is the output of the validate.sh

output of validate.php

Should i migrate to the newer version of mariadb first?

thanks for your help

I have migrate to mariadb
then now the output of validate.php is this one


Component Version
LibreNMS 21.3.0
DB Schema No Schema (0)
PHP 7.4.16
Python 3.6.8
MySQL 10.5.9-MariaDB
RRDTool 1.4.8

[OK] Composer Version: 2.0.11
[OK] Dependencies up-to-date.
[OK] Database connection successful
[FAIL] Your database is out of date!
./lnms migrate

but when i launch the command i got

./lnms migrate

  • Application In Production!     *

Do you really wish to run this command? (yes/no) [no]:


Migration table created successfully.
Loading stored database schema: /opt/librenms/database/schema/mysql-schema.dump

In Process.php line 267:

The command “mysql --user=”${:LARAVEL_LOAD_USER}" --password=“${:LARAVEL_LOAD_PASSWORD}” --host=“${:LARAVEL_LOAD_HOST}” --port=“${:LARAVEL_LOAD_PORT}” --database=“${:LARAVEL_LOAD_DATABASE}” < “${:LARAVEL_LOAD_P
ATH}”" failed.

Exit Code: 1(General error)

Working directory: /opt/librenms


Error Output:

ERROR 1050 (42S01) at line 9: Table ‘access_points’ already exists

That’s tricky now … Your instance is so old that automatic upgrade seems to be failing. You’ll probably have to play with SQL to try to solve these. If you don’t monitor any devices with wireless, removing completely this table might be a way to move one step further … But you’ll probably face a few of these.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.