"Illegal offset type" when running discovery.php with the module cisco-cbqos


I’m looking for some help to get CBQoS monitored with LibreNMS. Currently it does now work, even after enabling both discovery and poller cisco-cbqos modules.

Thus I ran the command hereafter (using the CLI) and I found many errors: ./discovery.php -h <ip_address> -m cisco-cbqos -d
I get many messages saying Warning: Illegal offset type in /opt/librenms/LibreNMS/Component.php on line 163 and Warning: Illegal offset type in /opt/librenms/LibreNMS/Component.php on line 166.

Here is the complete output: https://pastebin.com/s9rhuNVy

Any idea?

It is a warning, the code will still operate. If it is not working there is another cause.

I don’t see any sql inserts in that debug output…

You mean any SQL inserts related to CBQoS? However, when I run the SQL query hereafter, I get results related to the QoS configured on the device:
SELECT C.id,C.device_id,C.type,C.label,C.status,C.disabled,C.ignore,C.error,CP.attribute,CP.value FROM component as C LEFT JOIN component_prefs as CP on C.id=CP.component WHERE ( device_id = '<device_id>' );

Maybe because they had already been inserted. If you see results in the webui, what is the issue you are having?

My bad… I thought there was a global CBQoS menu (like in Observium). I was able to find data and graphs on the right ports of the right devices.

LibreNMS is 100% open source and community supported, so if you want to see data presented a certain way, contributions are welcome.