Install and setup phpmyadmin or mysqlworkbench on librenms server

Hello - pretty new with ubuntu and Librenms. We were able to get it up and running, everyone loves it. I’m asked to install a gui for the mariadb for some staff to access data. I tried both myphpadmin and mysqlworkbench unsuccessfully, and was hoping someone would provide some advice to help specific to Librenms installation on Ubuntu 20.04. with nginx that we setup 2 months ago using the install docs on the Librenms website. Both of them indicated installation was successful, but we cannot get to the page and attempted using the various “try this” scenarios from the web. Thank you.

Hard to help when you’ve not said what’s not worked with phpMyAdmin for example. However if you setup the mysql login details from your .env file it shouldn’t have any issues.

Acknowledged - Thank you for your time and response. I have tried a few web “howtos” on installing phpMyAdmin on Ubuntu20.04, and am getting the same result, so I think I may be close but clearly still missing something.

Post install - When I try to access phpMyAdmin via Firefox, if I put in localhost/phpmyadmin or, I get redirected to the LibreNMS login page.

Here is one of the links I used for the install

One thing I noted was that from that howto - Step 4:
“create a symbolic link from the installation files to Nginx’s document root directory. If you followed the prerequisite LEMP stack tutorial, your Nginx installation’s document root is /var/www/your_domain/”.
I used /var/www/html - since there was no subfolder there and it contained what looks like the Nginx default welcome page index.nginx-debian.html.

From this link -
it recommended using /var/www/html/phpmyadmin - so I created a folder and used that location for the symbolic link, with the same result.

*Is there a different location I need to use for that symbolic link on the LibreNMS server?

I also saw a few threads that suggested editing config files
“configure PMA to use the correct socket. in replace
$cfg[‘Servers’][$i][‘host’] = ‘localhost’;
$cfg[‘Servers’][$i][‘socket’] = ‘/tmp/mysql.sock’;”

and also some that recommended changing config file values;
“vi /etc/phpmyadmin/ and enter the IPAddress instead of localhost”

I ran “sudo systemctl restart nginx” after each modification made

As you can see I’m pretty green with this stuff, but I am working on it. I would appreciate any assistance or recommendations that you would be willing to provide. Thank you.

You need to install phpMyAdmin in the web server root for LibreNMS if you want to access it at /phpMyAdmin/. That is /opt/librenms/html/ if you’ve installed it as per the docs.

Indeed we did install to the location specified in the docs. Thank you again for your time and feedback!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.