Install Woes

So, I am installing this on my ESXI 6.5 box. I am utilizing Ubuntu 20.04 as the medium. I am also rather new to this so I am following the instructions at:

I am following the instructions and I am at this point:

su - librenms
./scripts/composer_wrapper.php install --no-dev

At the “[email protected]:~$” prompt it is asking for a password

I have looked and don’t see what the password is. I have used my root and user passwords to no avail and using librenms as a password also yields no positive results.

What is the default password for this?

Thank you,


Forgot to add, this is the next prompt: [sudo] password for librenms:

i think you made a mistake
su - librenms, when translated to “normal language” is:
i am simple user XXXX and i want to become user “librenms”
to achieve this, i need “su” command (switch user)
and normaly, “su” will ask you for password

but, in you example,

At the “[email protected]:~$” prompt it is asking for a password

you are already become “librenms” user, as you could see from prompt
so your next step is:
1 ./scripts/composer_wrapper.php install --no-dev
2. exit

Understood but now it wants a password. These are the exact instructions from the LibreNMS site to build your own system.

It is prompting for a password but there is nothing about a root password for switching over to the librenms user.

These instructions are from: Installing LibreNMS - LibreNMS Docs so I’m doing exactly what is called for.

OK, I solved this issue. I just changed the password for librenms and that seems to have solved the problem. I have a new issue for another topic.

No need to set a password for the librenms user (and you probably shouldn’t, as with any other user account created specifically to run a service rather than intended for interactive logins) you just need to run su as root, as root always has the ability to change to a user account even one without a password set.

So you should have been doing sudo su - librenms

Then enter your root password as you would with any other use of sudo. Sudo elevates you to root, so the su command gets run as root, that allows you to change to that user even though that user does not have a password enabled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.