Invalid type for: snmp.timeout

How do I fix this error?


In config.php

$config['snmp']['timeout'] = 5; # timeout in seconds

$config['snmp']['retries'] = 10; # how many times to retry the query

$config['snmp']['exec_timeout'] = 1200; # execution time limit in seconds

I have exactly the same issue. Any help to clarify this error, will be highly appreciated.

Hi we are running into the same issue when attempting to configure snmpv3.

Any help would be really appreciated.

Just to add that I’m seeing the same issue in version 22.3.0 - not sure when or with what version the problem began as I haven’t been into that settings page for a long time.

To those having this issue, configuring the timeout in config.php using $config['snmp']['timeout'] = 5 still works for SNMP v3, which can be confirmed by looking at the output of a capture debug session where you can see the correct command line option being provided to snmpget.

It appears to only be a bug in the GUI display of this setting.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.