IRC not connecting

Have tried to follow doc’s on setting up the IRC in Librenms to no avail. Found Laf’s example from June to check against our config, but still doesn’t connect/join?

Here is our config less FQDN

// IRC Bot configuration
$config[‘irc_host’] = ‘’;
$config[‘irc_port’] = ‘6667’;
$config[‘irc_maxretry’] = 3;
$config[‘irc_nick’] = ‘LibreNMS’;
$config[‘irc_chan’] = ‘#noc’;
$config[‘irc_alert_chan’] = ‘#noc’;
$config[‘irc_authtime’] = 8;
$config[‘irc_debug’] = false;
$config[‘irc_alert’] = true;
$config[‘irc_alert_utf8’] = false;
$config[‘alert’][‘transports’][‘irc’] = true;

Looking to see if anyone sees an issue.

this maybe a dumb question but did you check your firewalld on your server?

You have started irc.php haven’t you?

firewall is ok,we’ve tested that

laf, we thought it would have started automatically once the information was input to the config.php, no where in the doc’s does it say to do ./irc.php

It’s all good now that we ran ./irc.php.

Also one of our engineers made a very basic systemd start up script in /etc/systemd/system/librenms-irc.service set to start at boot but it can be stopped or started just like any other systemd script such as systemctl start librenms-irc.service

in case you 'd like to have it

Description=Librenms IRC bot



Thanks @allano337. You should contribute that back to the code base by submitting a pull request. You can also update the docs at the same time :slight_smile:

pull request # 7084 has been opened.