Issues on distributed polling

I trying to deploy one more server on distributed polling mode.

I guess that I’m on right way but some times my poller had this log:
This system is already joined as the poller master.

I observed that if I change the “$config[‘distributed_poller_name’]” it back to work.

That variable has to be unique per poller. You don’t need to set it but if you don’t we use the systems hostname so I’m guessing you might have cloned your poller which would explain it.

I cloned the second server from the first and changed the configs, but I fixed the pooler name, take a look:

$config[‘distributed_poller_name’] = ‘LibreNMS’;
$config[‘distributed_poller_group’] = ‘0’;

$config[‘distributed_poller_name’] = ‘LibreNMS-2’;
$config[‘distributed_poller_group’] = ‘1’;

Yeah that’s how it should be.

Ever that i rebooted the second server, I have to rename it again, after rename, it back to work.

Also I deleted the old name on db.

Thats normal?!

I deployed a new serve, everything begin good, but after few times, the same problem:

This system is already joined as the poller master.

That makes no sense with that config you have but if the actual vm is renaming itself, fix that first.

I rebuild all servers from zero and everything is working now. :slight_smile:

But the graphs don’t working.

When I ran the rrd command on console by root it worked, by user not (ERROR: Could not save png to '/tmp/xxx).

On webui, other error: ERROR: rrdc_flush (device/mempool-cemp-5000.1.rrd) failed with status -1.

Post the output of ./validate.php


Component Version
LibreNMS ebdfbd00d8bc61dbe00fd361278eeb4938f78d19
DB Schema 191
PHP 7.0.19-1~dotdeb+8.1
MySQL 10.0.30-MariaDB-0+deb8u2
RRDTool 1.4.8


[WARN] Your install is out of date, last update: Mon, 15 May 2017 22:45:02 +0000
[OK] Database connection successful
[OK] Database schema correct

Follow my config.php

Database config

$config[‘db_host’] = ‘localhost’;
$config[‘db_port’] = ‘3306’;
$config[‘db_user’] = ‘xxxx’;
$config[‘db_pass’] = ‘xxxx’;
$config[‘db_name’] = ‘librenms’;
$config[‘db_socket’] = ‘’;
$config[‘db’][‘extension’] = “mysqli”;// mysql or mysqli

// This is the user LibreNMS will run as
//Please ensure this user is created and has the correct permissions to your install
$config[‘user’] = ‘librenms’;

Locations - it is recommended to keep the default

$config[‘install_dir’] = “/opt/librenms”;

This should only be set if you want to force a particular hostname/port

It will prevent the web interface being usable form any other hostname

$config[‘base_url’] = “”;

Enable this to use rrdcached. Be sure rrd_dir is within the rrdcached dir

and that your web server has permission to talk to rrdcached.

#$config[‘rrdcached’] = “unix:/var/run/rrdcached.sock”;

Default community

$config[‘snmp’][‘community’] = array(“public”);

Authentication Model

$config[‘auth_mechanism’] = “mysql”; # default, other options: ldap, http-auth
#$config[‘http_auth_guest’] = “guest”; # remember to configure this user if you use http-auth

List of RFC1918 networks to allow scanning-based discovery

#$config[‘nets’][] = “”;
#$config[‘nets’][] = “”;
#$config[‘nets’][] = “”;

Uncomment the next line to disable daily updates

#$config[‘update’] = 0;

$config[‘distributed_poller_name’] = file_get_contents(’/etc/hostname’);
$config[‘distributed_poller_group’] = ‘0’;
$config[‘distributed_poller_memcached_host’] = “”; #(selfip)
$config[‘distributed_poller_memcached_port’] = 11211;
$config[‘distributed_poller’] = true;

$config[‘rrdcached’] = “”; #(selfip)

$config[‘memcached’][‘enable’] = true;
#$config[‘memcached’][‘host’] = “”;
#$config[‘memcached’][‘port’] = 11211;

$config[‘update’] = 1;

I’m guessing you have rrdcached setup wrong, what’s the start up options?

Please use pastebin or to post text, it’s unreadable when you just paste it into posts.

Great @laf

After review the rrdcached config, now I can see the graphs for devices polled by default poller group, but devices polled by remotes pollers inst generating graphs.

Need I install rrdcached on remote pollers too?

No but they need access to the rrdcached setup + the ability to create files like over nfs or rrdacached 1.6 (untested)

You are right (as ever).

I using rrdcached 1.5, then I discovery files on defauld poller group, after that I change for the other poller group. everything working fine now :slight_smile: