IT Watchdogs wxgoos

I have an IT Watchdogs wxgoos. It looks like it’s a supported device, but when I add it the graphs all show “Error Drawing Graph” and it doesn’t seem to pull any data. What I’ve tried so far is to update wxgoos.yaml to point to the MIB file which I’ve added but that didn’t help so I ran scripts/github-remove -d to put things back.

-bash-4.2$ ./validate.php

Component Version
LibreNMS 1.58.1-53-g15e29a4
DB Schema 2019_12_16_140000_create_customoids_table (148)
PHP 7.3.13
MySQL 5.5.64-MariaDB
RRDTool 1.4.8


[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

If you are having troubles with discovery/polling include the pastebin output of:

./discovery.php -h HOSTNAME -d | ./

./poller.php -h HOSTNAME -r -f -d | ./

It does seem to identify the device:

System Name


Resolved IP

Operating System

ITWatchDogs Goose

Object ID





1year 119 days 13 hours 48 minutes 35 seconds



Lat / Lng

xxx, yyy (removed)

To add more information this device only supports SNMP v1. I did create a support module for SevOne that was able to read the device including a synthetic indicator to also provide the values in Fahrenheit so I know that SNMP is working on it.