Latency graph option missing from all devices

====================================

Component Version
LibreNMS 22.3.0-13-g6214157e9
DB Schema 2022_02_03_164059_increase_auth_id_length (235)
PHP 7.4.3
Python 3.8.10
MySQL 10.3.34-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2
SNMP 5.8

====================================

[OK] Composer Version: 2.2.9
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[INFO] Detected Dispatcher Service
[FAIL] Missing PHP extension: memcached
[FIX]:
Please install memcached
[WARN] Your local git contains modified files, this could prevent automatic updates.
[FIX]:
You can fix this with ./scripts/github-remove
Modified Files:
includes/definitions/rutos.yaml
poller-wrapper.py
rrd/.gitignore

Hello,

I’ve only just noticed this, but the ‘Latency’ option that appears in each device we monitor is missing:

When I look on our other instance of LibreNMS we see it there:

How do I get it to show?

Thanks

It’s only shown if you have any data in your device_perf table for that device.

If you don’t have data in there then you have either disabled icmp_check (lnms config:get icmp_check) or you have this turned on for the device

When I run that command it says true which I think means it’s enabled?

How do I check the device_perf for a device?

select * from device_perf where device_id=X;

Replace X with your device id.

This is what I get for all devices I’ve tried:

Database changed

MariaDB [librenms]> select * from device_perf where device_id=491;

Empty set (0.001 sec)

MariaDB [librenms]>

Have you checked you haven’t turned off ICMP as per my screenshot?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.