LDAP - Auth Level 10 but not admin on GUI


#1

Hey everyone,

I have been searching for some issues here and found a few related to mine but can’t seem to get it working correctly. I am having issues getting the LDAP group levels set properly. I can authenticate with LDAP and receive a level => 10 on my user however in the webgui it seems to have level 0. Here is the paste of an auth_test.php and validate.php:

Auth_Test.php:
Authentication Method: ldap
Password:
Authenticate user xxxxxx:
AUTH SUCCESS

User (xxxx):
username => xxxxxx
realname => xxxxxx
user_id => xxxxx
email => xxxxxxxxx
level => 10

Validate.php:

Component Version
LibreNMS 1.47-20-gef8d7adad
DB Schema 279
PHP 7.2.13-1+ubuntu18.04.1+deb.sury.org+1
MySQL 5.6.42
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] You have not added any devices yet.
[FIX]:
You can add a device in the webui or with ./addhost.php
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.


#2

Found that the database is showing my user as level 0, even though if I run the auth_test.php it returns it as 10.

mysql> select username, auth_type, level from users;
±----------±----------±------+
| username | auth_type | level |
±----------±----------±------+
| admin | mysql | 10 |
| mhayes | ldap | 0 |
±----------±----------±------+


#3

Usually this is because you have not chosen a good uid attribute or something like that.


#4

Resolved this last night. I had an improper set of quotation marks in my bind account password which borked it.