Libre NMS update issue

in out version we have updates enabled automatically. Please see below:

When I check the version I can see that its set to 22.9.0 and the database scheme version is set to 2022_09_03_091314_update_ports_adsl_table_with_defaults (246)

I believe the latest version is 24.5.0

When I run a manual update using ./ it looks like it runs but the version dosent update even after a server restart.

Does anyone have any ideas how to fix this?



When you run ./ have you checked the log file for anything of relevance? Pretty odd i’ve not had an issue as each time i run it manually it updates the version.

Anything in validate?

Hi and thanks for your reply.

I will see if I can check the log file. Out of curiosity, where are you checking to see if the update ran successfully? I just want to make sure I am looking in the correct place.

Thanks for your help.


If the update ran successfully then you’re LibreNMS version (as of right now) should be version ‘24.5.0’. If it’s not then it wasn’t successful in some kind of way

run ./ and then check the log file afterwards. Also check your ./validate for issues that could be stopping the update.

Been seeing people with python issues blocking updates too.

Hi both,

thanks for your help. I can see that the php is out of date and python has a warning.

We are using Linux Ubuntu 20.4 version. D you know what the commands are to upgrade php and python?

thanks again.

sudo apt install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install php8.2

Restart following this

thanks Speechy. When you say restart do you mean sudo reboot?

also do I need to remove the old php version or just run the commands you have sent?

thanks for your help.

Just do ‘sudo shutdown -r now’ which will do the trick. It’ll fully shutdown and then restart.

Installing the newer php version will upgrade the existing package.

Hi Speechy,

thanks for that. Now we are receiving this error after upgrading the php to 8.1

do you know how to fix that?

thanks a lot.

Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 8.1.0”.



it looks like the apache is erroring since we updated.


The Apache error log may have more information.

With all respect, you might want to show some more effort

Worth upgrading php to 8.2 or 8.3 but do it with care.

PHP: Supported Versions - 8.1 is no longer supported.

thanks Speechy. I will try that.