LibreNMS Docker Container Validate Error for Scheduler


I’ve installed LibreNMS within a Docker container.
During the validation process, I encountered an error stating “FAIL: Scheduler is not running.”

I ran the fix command within the LibreNMS container but the issue persists.
I looked at the contents of the “librenms-scheduler.cron” file, I found the following:

librenms:/opt/librenms#  cp /opt/librenms/dist/librenms-scheduler.cron /etc/cron.d/
librenms:/etc/cron.d# cat librenms-scheduler.cron 
* * * * * php /opt/librenms/artisan schedule:run --no-ansi --no-interaction > /dev/null 2>&1

Does this look right? Could someone please advise on what might be causing this problem?
Any help greatly appreciated! Thanks!

I have tried the fix steps mentioned in this thread but no luck :disappointed: Docker container install - scheduler not running and ServerName - #3 by thenetworkpro

If you come from this post Docker container install - scheduler not running and ServerName

Error 1:
FAIL: Scheduler is not running - This I still have no idea, will update it if I get it to work.

Error 2:
FAIL: ServerName is set incorrectly for your web server - This is pretty easy just need to use that last brain cell lol.

Solution For Error 2:
Web UI > Settings > System > Server > Specific URL: http://IpAddressHere:8000/ (You need to paste that, replace the middle section with your Client’s IP address, and 8000 is the default port but if you’re using a different port replace it here. (I didn’t try using host-name, maybe it works too, you tell me later)

1 Like