Librenms does not return the Asterisk service graphs

Tags: #<Tag:0x00007f84b1eba1a8>

Result validate.php

Component Version
LibreNMS 1.48.1
DB Schema 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP 7.2.15-1+ubuntu18.04.1+deb.sury.org+1
MySQL 10.3.8-MariaDB-1:10.3.8+maria~jessie
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.4
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[FAIL] The poller (monitoring) has not completed within the last 5 minutes, check the cron job.
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
[FIX]:
Check your poll log and see: http://docs.librenms.org/Support/Performance/
Devices:
CBV-SW-02
CBV-SW-01
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN] Your install is over 24 hours out of date, last update: Wed, 30 Jan 2019 20:53:43 +0000
[FIX]:
Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.
[WARN] Your local git branch is not master, this will prevent automatic updates.
[FIX]:
You can switch back to master with git checkout master
[FAIL] Some folders have incorrect file permissions, this may cause issues.
[FIX]:
sudo chown -R librenms:librenms /opt/librenms
sudo setfacl -d -m g::rwx /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/
sudo chmod -R ug=rwX /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/
Files:
/opt/librenms/rrd/SMTP-x67/app-postfix-2.rrd

Hello,

My Librenms server run under Docker. I have a problem with the service asterisk, I set up the monitoring of the service asterisk by following the tutorial of this page “https://docs.librenms.org/Extensions/Applications/#asterisk” but Librenms do not return the graphics
I can execute the script with the right permissions
41

Thanks for your help,

What does it say when you run the poller debug or snmpwalk? Likely the snmpd user cannot run /etc/snmp/asterisk…

thank you for your reply,
when I run the poller and discovery, the Asterisk service is automatically discover my I do not see the information that is on the result of the script

Yeah, this means there was output, but likely the script failed with permission denied.

Go to the gear on the device, select capture > poller > run. That will show the output. Just do a search for asterisk on that output.

I have this as a result of research

N:U:U:U:U:U:U:U means it didn’t get any data from the app. You need to scroll up. Also, posting text instead of screenshots of text is more helpful :wink:

Hello,

What part do you need exactly for debugging?

thank you,

I’m trying to help you debug. You need to read through the output. There will be an SNMP command followed by the output of the snmp command (from your target server).

Most likely this will say “permissions denied” because your snmpd service on the remote server cannot run the asterisk script.

You need to log in to that server and either modify permissions, use sudo, and/or modify selinux.

I was able to advance on the problem and I managed to see the result of the script asterisk in the output of the poller for a moment, but today the poller does not display the result of the script

Poller Output:

Load poller module applications

SQL[SELECT * FROM applications WHERE device_id = ? [13] 1.37ms]

SNMP[’/usr/bin/snmpbulkwalk’ ‘-v2c’ ‘-c’ ‘COMMUNITY’ ‘-Oqv’ ‘-M’ ‘/opt/librenms/mibs:/opt/librenms/mibs/supermicro:/opt/librenms/mibs/dell’ ‘udp:HOSTNAME:161’ ‘.1.3.6.1.4.1.8072.1.3.2.4.1.2.8.97.115.116.101.114.105.115.107’]

“”

RRD[last ASTERISK-TEST/app-asterisk-stats-8.rrd --daemon unix:/var/run/rrdcached/rrdcached.sock]
RRD[update ASTERISK-TEST/app-asterisk-stats-8.rrd N:U:U:U:U:U:U:U --daemon unix:/var/run/rrdcached/rrdcached.sock]
[RRD Disabled]
SQL[UPDATE applications set app_state=?,app_status=?,timestamp=NOW() WHERE app_id = ? [“UNKNOWN”,"",8] 4.2ms]

SQL[SELECT * FROM application_metrics WHERE app_id=? [8] 1.19ms]

: …

Runtime for poller module ‘applications’: 0.0315 seconds with 4720 bytes
SNMP: [1/0.02s] MySQL: [3/0.01s] RRD: [2/0.00s]

Good afternoon

I’m facing the same problem
when I run the poller on the device
in the asterisk part it gives me the following error

asterisk, app_id=5 SNMP[’/usr/bin/snmpbulkwalk’ ‘-v2c’ ‘-c’ ‘COMMUNITY’ ‘-Oqv’ ‘-M’ ‘/opt/librenms/mibs’ ‘udp:HOSTNAME:161’ ‘.1.3.6.1.4.1.8072.1.3.2.4.1.2.8.97.115.116.101.114.105.115.107’]
“Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)”