Librenms page not working properly

Librenms page not working properly, it shows few options and page not fully displaying and sometimes got 404 error like this, please check

Can you please help me to solve this issue,

Please run


we have ran ./validate.php
can you check this,

A fix for the validate script is on the way.

But I think it doesnt affect your blank pages.

Since when you see that issue?

We are facing this issue for past two days.

Then it totally has nothing to do with the validate.php fail that was merged few hours ago. For that, run ./ to get your validate working again.

About your opening issue, did you changed any part of your webserver config or the base_dir in your librenms config?

No, We haven’t changed anything on the server.
We just ran ./ after we faced the issue.

Open browser console (F12) then refresh.

Whats that telling you? what is failing?

we tried in browser console, it finally shows error like this “Gridster is not defined”
for your reference,

now we ran ./validate.php it shows like this

The first image shows 404 not found.

For the second, did you modified any of those files?

No, we don’t make any changes. Still librenms page shows like this

Run the suggested command ./scripts/github-remove -d then run ./

we have tried

./scripts/github-remove -d


but no changes

Maybe go to Global Settings -> System -> Server and make sure Specific URL points your librenms url