LibreNMS passing groups to Oxidized

Greetings,

I have different username/passwords for my devices based on geography.
I have my devices in groups in LibreNMS based on geography. (The groups are created by matching a string in the SNMP location.)
Everything in LibreNMS looks as it should.

In oxidized, I have a default username/password, that works for the devices with the default credentials.
In my oxidized config, I have a section under “models” where I give unique credentials for the devices of a specific model. This works.

In my oxidized config, I created a group, that matches the group name in LibreNMS, in here I put the credentials for this group, this does not work. Oxidized is still trying to log into these devices with the default credentials.

Any idea how I can resolve and/or troubleshoot this? Is there a way to validate that oxidized is getting passed the correct group?

Hi,

First thing, check you have followed this doc and specified the groups in config.php:
https://docs.librenms.org/#Extensions/Oxidized/#working-with-groups

Oxidized webui will tell you the group being used.

We use that same setup (minus having creds for models) and it works for us. Might be worth sharing your config.

According to the web, the only group in oxidized is “default”.

in my LibreNMS, I defined a group called “RemoteSwitches”.
I’ve tried adding the following to my LibreNMS config.php:
$config[‘oxidized’][‘group’][‘location’][] = array(‘regex’ => ‘/rm/’, ‘group’ => ‘RemoteSwitches’);

This didn’t help.

I also have “enable return of groups to oxidized” set to yes.

Below is why oxidized config.

username: [REMOVED]
password: [REMOVED]
model: comware
interval: 3600
use_syslog: false
debug: false
threads: 30
timeout: 20
retries: 3
prompt: !ruby/regexp /^([\[email protected]]+[#>]\s?)$/
rest: 127.0.0.1:8888
next_adds_job: false
vars: {}
groups: {}
group:
RemoteSwitches:
username: [REMOVED]
password: [REMOVED]
models: {}
pid: “/home/oxidized/.config/oxidized/pid”
input:
default: telnet, ssh
debug: true
ssh:
secure: false
output:
default: git
git:
user: [REMOVED]
email: [REMOVED]
repo: “/var/lib/oxidized/configs/default.git”
source:
default: http
http:
url: http://127.0.0.1/api/v0/oxidized
user: [REMOVED]
pass: [REMOVED]
map:
name: hostname
model: os
headers:
X-Auth-Token: ‘[REMOVED]’
model_map:
cisco: ios
juniper: junos
hp: comware
3com: comware
models:
panos:
username: [REMOVED]
password: [REMOVED]

I’d say that either the devices location doesn’t contain rm or your have some other config in config.php stopping it, pastebin your config.php with login details redacted.