LibreNMS PHP 8.1 on Ubuntu 20.04 LTS Required?

After new Install the install wizard require to install PHP 8.1? I used the manual at Installing LibreNMS - LibreNMS Docs

Regards

3 Likes

It seems like PHP 8.1 becomes mandatory in September. I got the message by checking my installation via validate.php. But like you recognized it seems that the documentation is not up to date. But to be honest the installation of PHP 8.1 was a lot easier than I feared.
Long story short you need to add the repository sources for PHP and install 8.1 instead of 7.4. But the rest worked exactly like in the documentation. :slight_smile:

Ok This might be an issue for all of us who use the Raspberry pi as that is not currently an option