LibreNMS Polling overriding manual port-speed values

I’m trying to set up an alert system for a couple of our locations, but the problem is that the speed is set to 10mbps when we can easily get 10gbps over it. I tried to manually set the port speed by clicking the gear icon, going to Edit > Port settings and changing the ifSpeed. When I click save, it will set it to the value I put in, but next time it polls it resets it back to 10mbps. Is there a way I can override this without disabling polling? The device that’s polling at 10mbps is a MikroTik RB1100AH.

Hi @Noah_McDonald
I don’t think this is possible unfortunately.
You should open a case with mikrotik to ask them to report the value correctly. This is a bug only them can correct. Setting manually all port cannot be a good solution anyway.