LibreNMS / Seafile App


I’ve gone through setup of LibreNMS and Seafile Applications - LibreNMS Docs but still can’t get anything to show up in web UI. The graphs show “error drawing graph” on app page for Seafile.

Is there anything else I need to take into consideration besides what documentation states on Seafile setup?


when running


by hand
do you get a valid json returned?

Yes, I get the valid json when i run that manually. I ran manually from LibreNMS and I get " seafile:-2:Empty return from snmp_get."

have you restarted snmp server after adding extend to snmp?

Yes, I restarted SNMP.

I think issue might be timeout on Librenms side when it’s running that Seafile script. In debug mode of LibreNMS I can see SNMP executing the script and waits less than 2 seconds before continuing. However, when I run it manually on Seafile server, I’m noticing it takes 5-8 seconds for API to return the data.

Also, I noticed that Seafile plugin was able to gather the data when we were doing maintenance on Seafile server and we didn’t have any active users.

I’m not sure if this helps troubleshooting this and maybe fixing it.


This is what I see within LibreNMS. Not sure if above comment and this helps troubleshoot the issue.

when doing snmpwalk on librenms Server did you receive Seafile data?

Looks like SNMP was timing out so I just set custom timeout time and that seems to have fixed the issue. Thx @SourceDoctor

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.