LibreNMS Shows Port down


#1

When asking for help and support, please provide as much information as possible. This should include:

  • Steps to reproduce an issue.
    If you go to ports then down nothing shows in the list, but it still shows 1 in the drop down.

  • The output of ./validate.php
    [email protected]:/opt/librenms# php validate.php
    ====================================
    Component | Version
    --------- | -------
    LibreNMS | 1.51-52-g312d35dd9
    DB Schema | 2019_02_10_220000_add_dates_to_fdb (132)
    PHP | 7.2.18-1+0~20190503103213.21+stretch~1.gbp101320
    MySQL | 10.1.38-MariaDB-0+deb9u1
    RRDTool | 1.6.0
    SNMP | NET-SNMP 5.7.3
    ====================================

[OK] Composer Version: 1.8.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

If it’s an issue with the WebUI then please consider including a screenshot and the browser version you are using.

If you are having troubles with discovery/polling include the

pastebin output of:

./discovery.php -h HOSTNAME -d | ./pbin.sh
./poller.php -h HOSTNAME -r -f -d | ./pbin.sh

If you need to post any text longer than a few lines, please use a pastebin service such as https://p.libren.ms using non-expiring pastes.


#2

Is it the same in your web browser incognito mode ?

Are you logged in with an account that has access to all ports ?


#3

Yes I’m logged in as the only admin user. And yes it’s still there in incogneto


#4

Try check and search these boxes individually 1 by 1, to see if you gain any results.


#5

The menu seems to not ignore disabled ports…


#6

#7

Thank you for all of your help. I went thru and cleaned up ports and was able to get that stray down port gotten rid of. I’m not sure which port did it, but one of them did. Thank you.