LibreNMS with php8.1 crash at Weathermap installation


i’m using ubuntu server 22.04 and i installed on it librenms i follwed the instraction in the documentation every thing work fine, when i tryed to install weathermap and enable the plugin from GUI i have this message:

Whoops, looks like something went wrong.

this is the output from console:

[email protected]:~$ ./validate.php
Component | Version
--------- | -------
LibreNMS  | 22.7.0-12-g7071db98a
DB Schema | 2022_07_19_081224_plugins_unique_index (244)
PHP       | 8.1.2
Python    | 3.10.4
MySQL     | 10.6.7-MariaDB-2ubuntu1.1
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Composer Version: 2.3.10
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    rrd_dir is writable
[OK]    rrdtool version ok
[email protected]:~$

can you help me please

HI Mekki, I was coming here to get some help and the fact that nobody has replied to you means that I’m probably SOL. :wink:
But… I have been setting up LIbreNMS with 22.04 and PHP 8.1 and ran into the same problem. I’m not sure if I had it on 7.4 or not, but regardless of that…
I believe this is a bug, but what happens is that some code looks at your weathermap directories and throws up on it because there isn’t a map file. Something gets a null and it crashes Libre immediatly. YOu can however go to the editor and create a map even when Libre is blowed up. (technical term).
Go to your server /plugins/Weathermap/editor.php… So and then create a map. You might need to go in there and change those output directories, but if you can get a map saved, it will fix your librenms and then you can go nuts. I hope this helps.

Thank you Daniel for your reply, i will test it and look if it woks for me.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.