LibreNMS with PlaySMS using Twilio as SMSC is not sending in E.164 Format


My problem is when i do test transport in LibreNMS that is using PlaySMS and Twilio as SMSC i get 63XXXXXXXXXX as oppose to the needed E.164 format +63XXXXXXXXXX. But when i tried testing it in PlaySMS in compose message, I entered the TO number in E.164 it sends out SMS messages successfully.

PlaySMS compose message test [SUCCESSFUL]

    • 2018-05-18 07:44:24 PID5afee6c84df63 - L2 sendsms_process # start
    • 2018-05-18 07:44:24 PID5afee6c84df63 - L2 simplerate_hook_rate_cansend # allowed user uid:1 sms_to:63XXXXXXXXX9 adhoc_credit:1000 count:1 rate: charge:0 adhoc_balance:1000
    • 2018-05-18 07:44:24 PID5afee6c84df63 - L2 sendsms # saving smslog_id:12 u:1 parent_uid:0 g:0 gw:twilio smsc:twilio s:12243130172 d:639XXXXXXX9 type:text unicode:0 status:0
    • 2018-05-18 07:44:24 PID5afee6c84df63 - L2 sendsms_process # saved smslog_id:12 id:12

LibreNMS test transport to PlaySMS [FAILED]

You enter the TO number, are you not just setting it wrong?

Hi laf,

I solved the problem, i think i’ve messed up the PlaySMS settings. I did installed PlaySMS again and just enabled the webservices token. It now works fine.

We can close this thread.