location "unknown" showing on map

When asking for help and support, please provide as much information as possible. This should include:

  • Steps to reproduce an issue.
  • The output of ./validate.php

If it’s an issue with the WebUI then please consider including a screenshot and the browser version you are using.

If you are having troubles with discovery/polling include the pastebin output of:

./discovery.php -h HOSTNAME -d | ./pbin.sh
./poller.php -h HOSTNAME -r -f -d | ./pbin.sh

If you need to post any text longer than a few lines, please use a pastebin service such as https://p.libren.ms using non-expiring pastes.


Component Version
LibreNMS 1.47
DB Schema 275
PHP 5.6.38-0+deb8u1
MySQL 5.5.55-0+deb8u1
RRDTool 1.4.8

[OK] Composer Version: 1.8.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

we have many devices throughout US and they show on our map. there are also few servers that dont have location address because we didn’t want to show them on the map. unfortunately if location is not set, it’s automatically set as “unknown” (BUG) and then put on map


apparently there is a pond called “unknown” where all our servers reside … (sunk? or competing with https://natick.research.microsoft.com/ )


You didn’t post the poller output…

Have you looked at the “All Locations” page?

What I’ve done is disabled geocoding and manually set all locations. Updating the sysLocation setting to something logical (like “Main DC”) and using the sysLocation override for dumb devices that don’t allow you to set sysLocation. Then I went through the All Locations page and made it nice. Went from >250 locations to a more accurate just over 60 locations.

Map looks amazing now and has no crap on it.