Looking for APC users to test an update

NerdBlender on GitHub has kindly added support for 3 Phrase APC UPS units which has been tested successfully. However we would like to have this tested by any APC users without 3 Phrase units to ensure nothing breaks.

If you can test, please perform the following:


More info on the PR can be found at: https://github.com/librenms/librenms/pull/5558

tried to apply the patch but got the following output:


What is your current version?

omponent Version
LibreNMS ecd467fee7e9a4444c0f4c35e7d3aaec46f0b850
DB Schema 168
PHP 7.0.13
MySQL 5.5.50-MariaDB
RRDTool 1.4.8

latests git ver

I’m unsure why here, i’ve even rebased that PR.

I’ve updated the instructions to point to our faq which you can use to add another users branch to test.

For one UPS:
2017-02-25 12:38:27 Sensor Deleted: current apcUPS 0 Phase 0 Output
2017-02-25 12:38:27 Sensor Deleted: charge apc 0 Battery Charge
2017-02-25 12:38:27 Sensor Deleted: load apc . Load
2017-02-25 12:38:27 Sensor Deleted: runtime apc upsAdvBatteryRunTimeRemaining.0 Runtime
2017-02-25 12:35:17 Sensor Added: load apc . Load
2017-02-25 12:35:17 Sensor Added: runtime apc upsAdvBatteryRunTimeRemaining.0 Runtime
2017-02-25 12:35:13 Sensor Added: charge apc 0 Battery Charge
2017-02-25 12:35:12 Sensor Added: current apcUPS 0 Phase 0 Output

For the second UPS:
2017-02-25 12:25:11 Sensor Added: current apcUPS 0 Phase 0 Output

For an APC PDU it added only the header graphs that are not polling any data

@laf I am pretty much in the same boat as @crcro

:59: trailing whitespace.

:68: trailing whitespace.

:440: trailing whitespace.


Component Version
LibreNMS c5531f70670383530f7f218f6cbb4bd335dbc44a
DB Schema 169
PHP 7.0.15-1
MySQL 10.2.4-MariaDB-10.2.4+maria~sid-log
RRDTool 1.6.0


Looks like the re-base didn’t worked out as this is the issue I see for weeks now with 5558

if is I try this approach:

git status

On branch master
Your branch is up-to-date with ‘origin/master’.
Untracked files:
(use “git add …” to include in what will be committed)


nothing added to commit but untracked files present (use “git add” to track)

git remote add NerdBlender https://github.com/NerdBlender/librenms.git

git remote update NerdBlender

Fetching NerdBlender
remote: Counting objects: 92, done.
remote: Total 92 (delta 79), reused 79 (delta 79), pack-reused 13
Unpacking objects: 100% (92/92), done.
From https://github.com/NerdBlender/librenms

  • [new branch] 1.22 -> NerdBlender/1.22
  • [new branch] 1.22.01 -> NerdBlender/1.22.01
  • [new branch] issue-2733 -> NerdBlender/issue-2733
  • [new branch] master -> NerdBlender/master

git checkout issue-5558

error: pathspec ‘issue-5558’ did not match any file(s) known to git.

The branch you want is issue-2733

I have remerged - so should be OK now