Mikrotik Routers - Interface errors not being graphed (collected?)

I’m not really sure if this is a “device request,” or more of a “device enhancement”… I have a bunch of Mikrotik routers (CCR1036, CCR1072, CCR2004) that I am polling with LibreNMS. I just discovered today that some interface statistics are not being collected, most crucially any interface errors (“etherlike” type statistics including FCS errors, code errors, etc).

Mikrotik seems to expose these via SNMP, but it isn’t being collected by Poller (or Discovery) from what I can see.

When I snmpwalk a device using an independent app (from Windows), the details are all below OIDs similar to:
interface index 1, Rx FCS errors - Mikrotik MIB translates this to mtxrInterfaceStatsRxFCSError.1 (Counter64)

The “SNMP” dump from Libre’s webUI doesn’t even show these OIDs in it though.

What would I need to do to get this info polled and mapped to a device’s graphs correctly? Ideally, I’d like to make the change in one place so it gets applied to all of our Mikrotik devices (rather than needing to modify each of them individually).

Output of ./validate.php - we have errors related to Smokeping (that I’m not sure how to correct, because I need them to be owned by the ‘smokeping’ user for smokeping to work; they are currently mode 0775 with ownership as “smokeping:librenms”):

    Component | Version
    --------- | -------
    LibreNMS  | 21.7.0
    DB Schema | 2021_06_07_123600_create_sessions_table (211)
    PHP       | 7.4.3
    Python    | 3.8.10
    MySQL     | 10.3.29-MariaDB-0ubuntu0.20.04.1
    RRDTool   | 1.7.2
    SNMP      | NET-SNMP 5.8
    [OK]    Composer Version: 2.1.5
    [OK]    Dependencies up-to-date.
    [OK]    Database connection successful
    [OK]    Database schema correct
    [FAIL]  We have found some files that are owned by a different user than 'librenms', this will stop you updating automatically and / or rrd files being updated causing graphs to fail.
    (all directories below smokeping folder, and they are owned by user: smokeping / group: librenms with mode 0775)

Having a discussion with myself, but…
First thing I realized was that “etherlike” stats are not collected by default, and the GUI does not provide a knob to toggle them. (In the same vein, PoE info isn’t collected either and doesn’t have a GUI setting.)

From the docs, buried in Advanced → Configuration Docs, are these gems (with no commentary on what they do):

$config['enable_ports_etherlike']       = 0;
$config['enable_ports_poe']             = 0;

After adding $config['enable_ports_etherlike'] = 1; to my config.php, I can now see Etherlike stats are being collected and graphed from a few JunOS switches we have… but not from the Mikrotik (RouterOS) hardware (CCR1036, 1072, and 2004).

“Basic” Ethernet errors don’t even seem to get collected from them, even though they do record that info (it’s visible from Winbox or SSH or even with an SNMPwalk).

I’m not sure how to begin editing the “definition” file for RouterOS to enable LNMS to properly grab this info? I imagine that I’ll need to provide a list of OIDs…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.